Route between ZeroTier and Physical Networks

Good afternoon Everyone!

I am starting using ZeroTier and need some help to solve a situation.

I installed ZeroTier-One on my notebook that I use at home, and on the PC of the work.

I pretend to access all de network devices on the work (gateway from ZeroTier network.

ZT Network Local Network
Work PC
Home PC

I created a managed route into ZeroTier via 172.30.306.223 (Work PC).

I cannot ping the even with the Firewall turned off.

Can someone help me? What am I missing or doing wrong?

Edit: My environment is windows

Hi @testestestes192
When you first installed Zerotier on both PCs, you should’ve at least ping access from and to both ends, especially if you turned the Windows firewall off.

Now for accessing resources on the work side, you could setup bridging between the Zerotier interface and the local network interface.

There is no tutorial that I know of, but basically you do something like this:

Hello @grendon

Thanks for your help.

After bridging de ZeroTier with the local network interface, I cannot ping the Work PC with the local IP from work either the ZeroTier IP. Firewall is off.

I noticed that after bridging the ZeroTier network interface became disabled.

Could be anything on ZT configuration?

Thank you.

From my understanding, you’ll need to create a static route on your router.

From the network diagram. It should be with a gateway of

I might be wrong as I’m also working on this. Hopefully someone from ZT can comment on this

Hello. You’ll need to enable routing on that Windows box (Work PC). I think they call it connection sharing or RRAS. It’s not available in every version of Windows as far as I know. I’m not aware of any tuturials but wouldn’t be surprised if there were are few out there.

Short answer: to enable routing to your local network you need to turn on NAT and Packet Forwarding.

  1. NAT’ing is required otherwise reply packets from devices on your LAN will be rerouted to the default gateway instead of being sent back to the ZT node. On Win10, turn on NAT by enabling Hyper-V.
    NetNat Module | Microsoft Learn

  2. Packet forwarding is required to send packets between interfaces (eg "Set-NetIPInterface -Forwarding Enabled )

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.