Segmentation fault on LMDE5 after install

Just installed Zerotier 1.10 on LinuxMint Debian Edition 5, zerotier-cli status returns “Segmentation fault”.
Any ideas on how fix this issue?

No help for zerotier 1.10 install on LMDE5.
Got to know when to quit, reverted back to 1.8.10.
All working good on LMDE5.

1 Like

So new to ZeroTier…Got Mac’s & iPhones working, but Linux Mint is having Segmentation Fault. Been looking, but can’t find command to revert back to an earlier version.

Uninstall zerotier
Download older version from Index of /RELEASES/
Install, join network again.

Will do…Q: I’m running Linux Mint 20.3 Cinnamon, so unsure which version of the debian versions…? If I look at the files, they all refer to zerotier-one_1.8.10_amd64.deb as the filename, so assuming there aren’t nuances for each?

Debian versions explained here Debian version history - Wikipedia
Read through to the Bullseye section, Debian 11 (Bullseye) It is based on the Linux 5.10
Mint 20.3 Cinnamon has kernel 5.4 (see uname -a or inxi -F), so Buster covers 4.19 to 5.9.
So your after the Buster version, and assuming u have a normal pc, amd64 is the right choice.
Hope that’s clearer than mud!

So I have the file downloaded, but must be doing something wrong…

sudo dpkg - i 'filename, to install the file

when I run systemctl enable zerotier-one.service , I get a permission denied.

when I run sudo ./zerotier-one -d, command not found

when I run sudo //var/lib/zerotier-one/zerotier-one -d, then I get cannot bind on local port 9993.

so, it’s clear I don’t know the commands to revert to previous version. Help a brother out?

Looks like you forgot sudo in front of that.

Sounds like it’s already running. It should be by default after installing. You can interact with it via the sudo zerotier-cli command. For example sudo zerorotier-cli info

So I run sudo systemctl enable zerotier-one.service, does run. When I then start the service, I get…

solarczar@solarczar-UCSC-C220-M4S:~$ sudo systemctl status zerotier-one.service
● zerotier-one.service - ZeroTier One
     Loaded: loaded (/lib/systemd/system/zerotier-one.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Thu 2022-07-07 13:30:27 CDT; 7s ago
    Process: 168917 ExecStart=/usr/sbin/zerotier-one (code=exited, status=1/FAILURE)
   Main PID: 168917 (code=exited, status=1/FAILURE)

Jul 07 13:30:27 solarczar-UCSC-C220-M4S systemd[1]: zerotier-one.service: Scheduled restart job, restart counter >
Jul 07 13:30:27 solarczar-UCSC-C220-M4S systemd[1]: Stopped ZeroTier One.
Jul 07 13:30:27 solarczar-UCSC-C220-M4S systemd[1]: zerotier-one.service: Start request repeated too quickly.
Jul 07 13:30:27 solarczar-UCSC-C220-M4S systemd[1]: zerotier-one.service: Failed with result 'exit-code'.
Jul 07 13:30:27 solarczar-UCSC-C220-M4S systemd[1]: Failed to start ZeroTier One.

the sudo zerotier-cli info gets bad command.

Can’t reproduce the segfault on a fresh & updated install of LMDE5. The install script does misdetect the os as Ubuntu 16.04, when it should likely detect it as a Debian Bullseye derivative. Even though it’s the binary built for Ubuntu 16.04, it still works by default though.

You can edit /etc/apt/sources.list.d/zerotier.list and replace instances of xenial (or whatever code name is in there) with bullseye, then the apt update/upgrade routine to install the package. (You may need to apt remove zerotier-one first).

Beyond that, I can’t yet tell why some folks are getting segfaults

1 Like

Thanks zt-grant
/etc/apt/sources.list.d/zerotier.list = deb Index of /debian/bullseye/ bullseye main = working great now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.