Sharing DLNA Server over ZeroTier Network

I Set up a ZeroTier network and invited my friends to it. Auto Assigned ip’s in the 192.168.20.70 - 192.168.20.100 range

Enabled Broadcasting

But they still cannot see my Plex DLNA Server. I’m a bit lost as to what else i need to do since there are very few online resources talking about the same topic.

i was looking into Ethernet Bridging but im not sure if its the right way to go since its a lot of work, even less documented and maybe not even related to the issue i’m having.

Any help would be greatly appreciated, Thanks

Hi! Sorry for the delay. Are the clients mobile devices? On mobile, plex/zerotier might not work for auto-discovery/LAN like operation.

Plex does some fancy networking stuff and I’m not 100% sure how all of it interacts with ZeroTier. Did you add the ZeroTier subnet into your plex config? Settings -> Network

Screen Shot 2020-09-01 at 3.25.58 PM

No mobile devices but no i haven’t added the Subnet into my plex config. it should be the same mask as as my default network though but i will try it.

On a Sidenote i switched Programm to Jellyfin but that should change little about how DLNA works.

Edit: Turns out that Jellyfin has no List of IP adreses to allow without auth…
Edit2:


It does have the list but only for changing bandwidth restrictions

That’s cool. What is the client, and which operating system is it running on?

VLC Media player but its intended for BigScreen Beta.
all devices are running on windows though

Your ZeroTier subnet isn’t the same as your physical subnet is it?

I tried to test with VLC on Mac, but VLC just hangs.
Kodi on linux worked as a client as soon as I enabled DLNA on it.
Is there a different client you can try just to double check?

yes it is. i made sure that it was exactly the same. is that bad?

Yes. Lately i have been using Windows Media player but im still looking for a good Alternative that i can use to verify if its working

Yes! :sweat_smile:.
Try just using any one of the premade ranges.


would this work?

That should be fine.

Tried it and still no difference. my friend is now on 192.168.10.18 but still cannot see my server.

Does ping work?

I’d check if the jellyfin people know what to do.

since this doesn’t work with either plex or jellyfish and i can’t see his server either im inclined to believe its a issue with broadcasting across the network.

I set up my laptop on the network and i can ping it just fine: image

for testing purposes i set up a node app to listen on port 3030 and had my friend check if he could connect to it.
So far he has always been able to reach me on my ip

On You picture: Destination net unreachable !!!
Network don`t work.

If it wouldn’t work it would simply say timed out. Net unreachable means there is no server running on that pc. Check the bottom because if i wasnt pinging a valid device ip it wouldn’t send me any packets back. So seeing as i recieved 4 packets im inclined to believe that the connection works.

Hi!
I think packets transfer only to 100.65.128.1 but not 192.168.15.19
100.65.128.1 nothink known about net 192.168.15.0/24

try use tracert 192.168.15.19 and see route how packets transfered

You friend can ping you zerotier address?
Plex server listen this address? Try cmd netstat -a and see listening zerotier_ip_address:port_pelx

so.
A: the trace to my laptop seems to be direct?

B: I cannot ping my friend’s ip:

But i can visit his adress. (i got him to run nginx for testing purposes)
image

My friend isn’t able to ping my pc but he can ping my laptop: image

his tracert to my laptop looks exactly the same as mine: image

so im confused as to why some parts are working and some parts arent

May be WINDOWS Firewall? Look in Google about blocking ping in windows.
And I dont understand whereyou use zertier, on PC or notebook?
Send ipconfig /all from both devices. And route print.