Snyology docker image restarting

I’ve followed the guide (Synology NAS | ZeroTier Documentation) to setup my DSM7 with Zero Tier. However, the docker container seems to be restarting every 15s.

I’ve tried attaching to the running container and it seems like the zerotier-one service doesn’t connect. Now if I run the entrypoint script manually I get the following:

Starting Zerotier-One
Wait for ZT service to come online before attempting queries...
zerotier-one: fatal error: cannot bind to local control interface port 9993

This is quite expected since the Zerotier-one process is running and is likely using the port 9993. However, it seems like the script waits 15 seconds and then kills the process.

The DSM has no special config, it’s actually new and doesn’t run anything. The status is always OFFLINE, and naturally, the client doesn’t join the network.

I figured it may be something with tun, so I went ahead and checked if it’s working. Additionally followed this guide to confirm : Fix TUN/TAP not available on a Synology NAS :: Memory Leak — Rui Marinho

How would I go about debugging this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.