[SOLVED] Four Devices but Two Of Them Cannot "See" Each Other

[Solution] Initially ZT was installed on the Ubuntu machine using Snap. It was working, as stated below, until it stopped working. However, I uninstalled ZT from the Ubuntu machine using Snap. I reinstalled it after a restart using Snap again and the same problem persisted, as described in the original post. I then uninstalled ZT again using Snap. I then restarted the machine and installed ZT (1.62) using the following command:

curl -s https://install.zerotier.com | sudo bash

Everything is now working again. The Mac and Ubuntu once again can “see” one another. I hope this helps somebody.

[Original Post below]


I am hoping someone can help me troubleshoot this issue I am having. I have four devices on a private network:

  1. macOS 11.1 [ZT version 1.62]
  2. Lubuntu 20.04 [ZT version 1.62]
  3. Ubuntu Server 20.04 [ZT version 1.62]
  4. iPhone 11, iOS 14.3 [ZT version 1.61]

All devices are visible in ZeroTier Central, online and assigned IP addresses.

Using the numbering for the devices above:

1 can ping 2, 4
2 can ping 1, 3, 4
3 can ping 2, 4

(All on the same LAN within the same building)

In short, the Mac and the Ubuntu server cannot ping one another. However, they could. They could ping one another, and I could SSH onto the Ubuntu Server etc.

The one major change has been upgrading the Mac from Catalina to Big Sur. I also don’t know when the ZeroTier version was upgraded on the Ubuntu Server (I read that some people had better luck with 1.4.6 on Linux and when upgrading to 1.6.2 their networks stopped working).

I have tried reinstalling ZeroTier on the Mac. I have removed the Mac from the network and re-added. I have taken down the firewalls on the Mac and the Ubuntu Server. Have also created a new, second ZT network, same issue. They still cannot ping or connect to one another.

Update: I listed the peers on each machine. When doing this on the Mac it shows the Ubuntu box sometimes as ZT version 1.6.2 and sometimes as ZT version 1.4.6. I think I may be onto something. How can I troubleshoot this finding further?

I am not too technical; however, any pointers to where and how I should be troubleshooting this problem would be appreciated. Thanks, and have a good and safe 2021.

[Edit: Updated things I have tried to resolve the issue]

We’re not the authors/maintainers of the Snap package. In fact, we’re not quite sure who is. We recommend doing exactly what you did and just install via the apt / curl | bash method.

Had similar issue between a windows host and a debian host (could not ping between them but they could both ping other host on same zt network).
Turns out deleting peer info on the debian host and restarting service solved the issue.
See this discussion: [Can't ping devices]
Might be related.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.