Can't ping devices

I struggled with this today with two specific devices, a raspberry pi and a debian linux machine, I could ping other devices next to them on the two remote networks, but not each other.

The solution that finally got them to work was as follows:
On both machines run the following to find your ID

sudo zerotier-cli info

200 info **999xxxxx99** 1.6.2 ONLINE

you need to copy that ID

On each machine, stop the zerotier service

sudo systemctl stop zerotier-one

Once they are off, you can delete the peer info on both machines

sudo rm /var/lib/zerotier-one/peers.d/999xxxxx99.peer

After you do that on both machines, restart the zerotier service

sudo systemctl start zerotier-one

They should now be able to communicate within a minute or so.
I hope this saves someone as much time as it took me to write this up. :nerd_face:


I can confirm I had similar problem with Zerotier on a debian 9.13 installation.
Could not ping the linux host from a windows host on same zt network.
Looking at traffic (tcpdump) i saw that arp requests for where not been replied.
Applying your solution (deleting peers and restarting service) solved the issue.

This also worked for me for with two ubuntu machines that couldn’t see each other, when other devices on the network could.

For Info the location of peers for different devices:
Mac OS X: /Library/Application Support/ZeroTier/One/peers.d/
Linux: /var/lib/zerotier-one/peers.d/
Windows: C:\ProgramData\ZeroTier\One\peers.d\

This also worked for me, with a ubuntu and a Debian box that couldn’t see each other (both on 1.6.2). Since 1.6.2, I’ve seen a lot of these issues and I guess this seems to be a temporary fix. I’ll try it for the other “pairs” of boxes that can’t talk to each other, hopefully it fixes all the instances I have :slight_smile:

edit: it did indeed fix four other cases where I had this issue between pairs of devices. All were on 1.6.2, some containers (LXC with Ubuntu), some VMs (Ubuntu and Debian).

Same issue and this also worked for me. 2 Raspberry Pi 4 systems running 1.6.2 that can no longer communicate. Worked fine until a 5 days ago and has been getting worse. Could always access both from a remote Ubuntu laptop without issues.

I’m sorry, but can I ask if I can do this process remotely? I have no physical access to one of the workstation with Ubuntu now.

I got the same problem as you described here. I have machine A (Ubuntu) can be access by the other machine B (Ubuntu), but can’t be accessed by machine C (Mac). However, I can ssh B via C.

I want to try your solution here, but if I remotely call “sudo systemctl stop zerotier-one” on machine A, will that just cut off my remote connection to machine A (via machine B)? Thanks.

I think if you delete the peer files, and then restart it will accomplish the same thing.
“sudo systemctl restart zerotier-one”

You should also update to the 1.6.4 version and see if it helps this problem