Static ip for clients

hi.
my zerotier working very well when ip addresses assigned auto. if i assign ip addresses manually, there is no connection. all clients online but i cant connect.
what should i do?

That should work. The IP address needs to be in the same subnet as the managed route.

but it is not working.

I just tried this and it is working now. I was working on it yesterday and had the same issue as you did. This time, I left the auto-assigned address on the system AND added a static address in the same range. Specifically, I specified a range of 192.168.192.1-192.168.192.250 (/24) and then added the static address to the system of 192.168.192.254. The system also has the ZT managed address if 192.168.192.96. I can ping both. So… maybe it will work for you if you leave the automatically assigned address on there as well - pretty hacky but so far it is working.

yes, it works when the automatically assigned ip address is not deleted. but this time every device has 2 ip address. there must be a way.

Can you open the little wrench icon for that member and check “Do Not Auto-Assign”
try that.

i tried, not worked.

also i tried to use my own managed route, but no success. i want to use 10.12.12.33/24. if i choose any other ip different from zerotier option, didn’t work.

The interface in my.zerotier.com isn’t working, or your device isn’t working?
Please try to leave and rejoin the network after changing the ip address.

I rebuilt from scratch. I have accomplished exactly what I wanted to do as I do not have any problems at the moment. Thank you for such a beautiful product.