Sudden lack of access from peers via DNS


Just setup 3 linux nodes and a macOS client last week on a private network. All nodes authorized.

I had this alternative working just great last week:

From my macOS chrome browser, I could access my.sub.domain just fine for a week - and now it’s timing out and claiming: “DNS_PROBE_FINISHED_NXDOMAIN”

Any ideas?

Also, I can curl and ping and ssh into the 3 linux nodes just fine across the zerotier network.

Help appreciated in advance. Thanks.

It’s also possible to put your ZeroTier Managed IP Addresses in public DNS. That is, purchase a domain name from a registrar and create A and/or AAAA records that point to your virtual IP addresses.

Assuming this is the method you’re using (it’s the section you linked to), then it’s probably an issue with your DNS server and not related to ZeroTier at all. Beyond that I can’t say what the issue could be.

1 Like

Yessir. That’s the method I’m using.

Hoping that wasn’t the answer…but thanks anyways.

Problem solved! @zt-grant, went down the dns rabbit hole you pointed out and started checking all local and domain provider settings. Turns out I just needed to change my laptops DNS servers to google public dns Then it worked again like a charm.

Like you said, nothing to do with ZeroTier! Which is incredible btw.

Perhaps your router is configured not to serve public DNS entries for RFC1918 address spaces. That could cause the errors you’re seeing

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.