Suddenly lost access to mapped drive

So my server at home is running ZT, and my laptop has a mapped drive letter giving me direct access to a shared folder on my home server for files that I access often. This has been working great for months.

Last night, the power went off at home for a couple hours, long enough to deplete the UPS, and the server shut down. This morning, everything is back up, but I no longer have access to my ZT folder from my laptop. I can ping the server, but the mapped drive is no good (Windows said something about a local name being in use?) and if I try to browse the share directly in Windows Explorer by the IP address, it just ponders for a bit, then opens a browser tab (?) saying “the connection has timed out”.
It’s almost like ZT is blocking the connection from its end, since the errors I’m getting are timeouts, not “connection unknown”, or whatever.

My ‘server’ is nothing more than an old Windows 7 desktop box with the ZT client running on it. It’s set up with a standard windows file share, and the way it was before, I could just punch in the ZT IP address from my remote machine and it would show the shared folder. Since this power failure, I’ve lost that ability. Nothing else has changed, to my knowledge.

When I try to connect to the same server from the Fx client (app) on my phone, it shows a green “good connection” indicator, but when I actually touch it to try to browse the files, it thinks a moment, then throws a “the network connection…timed out” error.

Just to be sure, I had someone local reboot the machine, and also check on the local LAN to make sure they can browse shares, and they can. The reboot made no improvement.

I can still ping the server, and can tracert it, but cannot access it any further.

Any idea what to try next?

No one?
How can i go about getting support for this?
I really need to have this connection back working…please?

It might be a firewall issue. Check the connection profile for the ZeroTier interface and the corresponding firewall rules for shares.

Sorry, thought I had already covered that. Must have been in another thread. :slight_smile:
The profile for all interfaces on the server side are set to “work” (private).
The Windows firewall is configured to pass all traffic from Zerotier processes.

Have you also checked the connection profile in “advanced firewall” so “privat” is enabled for the following Inbound Rules:

  • File and Printer Sharing (NB-Session-In)
  • File and Printer Sharing (SMB-In)

Also double check properties in advanced firewall to make sure the ZT interface is ticked in the “private” section.

I have now! :smiley:
This looks correct, right? (see image)

and this?

Looks ok to me. Can you ping both the ZT and the local eth address?

I can ping the managed ZT address, and the true external IP of the remote location (WAN IP) for sure. Not sure how I would go about pinging the local eth, or honestly what exactly you mean by that, sorry. I know just enough to be dangerous… lol

Run “ipconfig /all” and look for something like “Ethernet Adapter” and try to ping that address from another node on the ZT network.

Also check that the ZT interface really is “private” according to the firewall as the pic down below: Advanced Firewall->(Right click “Advanced Firewall…”)->Drop-down menu “properties”->Private Profile->Protected Network Connections->Customize…

So by local eth, you just mean the local IP of my server? That wouldn’t ever work, would it? I thought ZT only created tunnels to devices running the client. For example. If I’m running ZT on my server at home (I am), I wouldn’t automatically get access to all the other devices on the same LAN that the server is on from outside, would I? Maybe I don’t quite understand how this thing works… lol

As for the firewall stuff, I checked that setting, and I indeed do NOT see ZT listed there. Any idea how that got gone, or how to fix it?

It’s fixed!
I uninstalled and reinstalled the ZT client on my server, and everything seems to be working now.
It appears that something got broken in the background…who knows?
Hopefully I’ll remember this if it happens again. :slight_smile:
I still don’t have the ZT network in my firewall entries under protected connections. Weird.
Oh well, I’m back up and running, so I’m not complaining.
Thanks for your help!

1 Like

Glad it worked out! Regarding the fw, you can check if the zt interface appears under some of the other tabs “public” or “domain”.

It does not. I don’t see ZT anywhere in that section. Not sure why not.
I do see it listed on my laptop, which is the other machine I connect from.
That’s probably what caused this issue to begin with. No idea how it’s suddenly working again without those entries, but I’m done chasing this issue for now. :slight_smile:

1 Like

So the issue has returned. :frowning:
It worked great for a week or so, and today my mapped drive through ZT no longer connects.
I did the uninstall/reinstall cycle of the ZT client on my server, but that didn’t seem to do the trick this time.
I can still ping my managed ZT IP, but any other action fails. If I try to browse the share through windows explorer, for example, it thinks for a bit, then a web browser opens, and I get a message saying “The connection has timed out. The server at 192.168.XXX.X is taking too long to respond.”

It could very well have something to do with the ZT connection not being listed under “protected connections” in my firewall, but I have no idea how to get it back in that list. There’s no “add” option.
Any ideas? This is driving me bonkers, and killing my productivity.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.