Synology NAS not actually connecting

Hi - I’ve searched for other Synology issues reported here and no one seems to be this specific case.

I have two LAN networks connected via internet using ZT and works for everyone correctly except NAS2, as described below. More interestingly, NAS2 report status DIRECT connection and listed as peer by others, still cannot actually connect via SSH, HTTPS or anything else.

Network topology:


  • NAS1 <-> LAN1 switch <-> ISP Router1 <-> internet
  • PC1 Win <-> LAN1 switch <-> ISP Router1 <-> internet


  • NAS2 <-> LAN2 switch <-> Router2 <-> ISP Router3 <-> internet
  • PC2 Win <-> LAN2 switch <-> Router2 <-> ISP Router3 <-> internet
  • PC3 Ubuntu (moon) <-> LAN2 switch <-> Router2 <-> ISP Router3 <-> internet

VPS1 Centos (Moon) <-> internet

NAS1/NAS2: Synology docker installed as per zerotier official instructions.
NAS1/NAS2 have disabled firewall and no specific routing.
PC1/PC2: standard PCs
PC3: ubuntu headless PC
Router2 is the actual DHCP/Gateway for LAN2, a TL-ER6020, has enable UPNP and disabled firewall.
Router3 has UPNP enabled, and no firewall enabled.
NAS1/NAS2 are not orbiting moons. I tried that and NAS2 still not connected.

If I list peers in PC1/PC2/PC3/NAS1 all them have NAS2 listed as DIRECT
Conversely, if I list peers in NAS2, I can see the others listed as DIRECT too
So nobody is RELAY and everybody seems to be listed ok, as far as ZT status is concerned. But NAS2 is not really working even though is listed as such.

So I am a bit loss of what I am missing to get NAS2 behaving the same as the other nodes

Respoding to myself…
It looks like DOCKER image is not working on DSM6, even though it is listed as connected as per my previous description, it does not work, probably route table or something else from docker to the host is not actually kosher. Installing the old “package” v1.4.0 for DSM6 works ok. So I would not recommend using docker with DSM6.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.