Unable to connect to peer behind NAT

I’m running version 1.6.6 on all my machines on the latest archlinux.

In my setup, I have a number of boxes that are behind a NAT and one with a public IP. All at once, those behind a NAT stopped being accessible from devices behind another NAT, where they had previously worked from behind the same NATs. They remained accessible to the device with a public IP. It took a reboot of each to resolve this; restarting the service did not help. How can I avoid having to restart all of my boxes due to random errors like this?

When I attempt to connect to one of my NATed peers in this error state, it goes from not appearing in the peer list to appearing with no ip address, no version, and negative latency. I tried running the service build with debug messages on my outside machine, and attempts to connect to these appeared to cause some message about “fetching config” each time I tried to connect.

This issue just occurred again; it’s very frustrating having to deal with this. Any ideas on how to resolve it?

I am now seeing my entire network erroneously report that it is down from my.zerotier.com, even though some devices remain available.

Hi,
sorry we missed this earlier.
Unfortunately there’s no good way to know exactly where the issue is. What kind of devices are your NAT devices? It sounds like a NAT/firewall issue. Exactly where is hard to guess.