Unable to ping connected Windows 10 computers with McAfee running

I’ve not been able to ping two connected PCs running Windows 10 with McAfee running. When I turned of McAfee firewall, the ping was successful. I do not want to permanently disable McAfee firewall. I have included ports 9993 in both MCafee and windows firewalls but no luck. Any clues?

McAfee blocks ping requests per default, turn that off in McAfee and you should be good to go.

Thank you Gara. I will check that out.

@Gara. Just a follow up, the ping works now after disabling the suggested McAfee feature. However, the pcs are still not communicating.

If the pings work then they are communicating, but what are you trying to achieve? Is it for gaming, file sharing, RDP?

I have an app I can access on the local pc from a web based interface on another pc by just specifying the managed IP and a port. When I specify these without McAfee firewall, it runs ok.

So if you try to access the web based interface via the ZeroTier IP and with McAfee turned off it works, but when you turn McAfee back on it stops working?

That’s correct. It stops working with McAfee firewall on.

Does this app listen on port 9993 or on another port?

The app actually listens on another port actually. Let me try and get the app to listen on port 9993 and see what happens. stay tuned. Thanks for the help so far.

Switching ports to 9993 in the app’s configuration settings caused the app no to run. I guess 9993 port is dedicated to ZeroTier app? I may be wrong though

Yes, port 9993 is dedicated to ZeroTier, that’s why I asked, is the port that the app listens to allowed through the firewall? And do you have any other network configuration such as the ZeroTier flow rules that might interfere? And have you configured the firewalls on both devices to allow the app through?

Honestly just started using ZeroTier a few days ago. I used the default ZeroTier flow configuration. I have not configured firewalls to allow the app through. What I dont want to do however is start opening ports in the firewall that may get my pcs exposed. Let me see if the app is firewall configurable. Will get back to you in a min.

If you haven’t changed the ZeroTier configuration it should be open for everything.

You can open the port to only a specified network or a specific IP-address, not sure if McAfee allows that or not. So if someone from with an allowed IP tried to access the app they get through, if the IP is not allowed they will get a timeout or a denied response without getting through.

McAfee can only allow the app to be opened to a specified network and not specific IP address. When I opened the app port to all devices, it worked. But I have wait to understand the security risks before I activate this option. Thanks for the help. It was informative.

If you open the port on the ZeroTier network only, then someone would need to have access to that network or a device to that network to be able to access the app, everyone else would just see a closed port and would not be able to access your PC through that port. If you are the only one using that network you should be completely fine, if others are also using it I would suggest putting the PC in a DMZ in your home network to be safe in case the PC get’s compromised.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.