Unable to RDP or Ping zerotier node

Hi - I’ve had zerotier working on my mac and windows machines for well over a year now. Now suddenly I cannot rdp from the mac to the windows machine.

The mac machine seems to have a steady connection to the zt network (always shows up as active on the website member list). The windows machine seems to come and go for no apparent reason.

When the windows machine shows up as active in the members list, running a peers command from the mac does show it listed as a peer. However, I still cannot ping or RDP to the windows machine from the mac. I’ve tried rebooting both machines and have MS Remote Desktop upgraded to the latest release.

I’m very much a novice w/ this, so any pointers would be greatly appreciated. I’ve searched and read all similar topics that I could find, but haven’t found anything that will help.

Try uninstalling ZT on the Windows machine and re-installing. Maybe Windows firewall is blocking.
A reinstall may work.

Tried this, no joy. Appreciate the direction, any other ideas?

Try assigning a different IP address - there was another thread recently with similar symptoms that was corrected by changing the IP address.

Tried this as well, thank you for the suggestion. The windows PC was assigned a new IP the next time it poked its head up, but I still cannot connect to it.

I now won’t have in-person access to that pc for another couple days, may need to just wait until then and wipe/re-create the whole network and see if a fresh install across the board re-creates the magic.

Tried creating a new network as well - it joined and got a new IP immediately, but still couldn’t connect.

I tried uninstalling again, I used windows uninstall, then deleted the zerotier folders under Program Files and under AppData/Local, then rebooted. When I re-installed it still knew about my 2 zerotier networks and joined them…so I’m wondering if I missed something when doing the uninstall?

Found another ZeroTier directory under /ProgramData. When I deleted that and re-installed I had to re-add the windows PC to the ZT network…however I’m still encountering the same issue.

When I’m connected to the same router as the windows pc, I can (sometimes) connect to the ZT IP via RDP …no idea why it only works sometimes as I can always connect via RDP to the local IP. However, when I connect to the upstream router I once again cannot connect.

I’ve tried turning Windows Firewall off for Domains, Public and Private networks and it didn’t have any impact on the issue. I’m at a loss on what else to try. Nothing has changed in the configuration of either router since I had it working last month.

Added another windows machine that used to connect and have the same issue there, so it’s not a windows problem.

I created a network on tailscale and it worked immediately - so it seems like it’s some issue w/ Zerotier. I’d rather stay w/ zerotier, but if I can’t figure this out it looks like I’m moving.

Can you ping the Mac from Windows?