Unable to see apple airport express and time capsule devices via VPN

I’ve configured Zerotier on a raspberry PI and on a netgear router in an attempt to perform timemachine backups over VPN.

Unfortunately this doesnt work as my mac fails to discover the shared network devices such as the time capsule and the airport express devices when connected over the vpn.

I keep reading that it should “just work” but two days later it still doesn’t work, and honestly I’m out of ideas.

Can anyone please point me towards a guide that allows bonjour/mdns broadcasts over VPN?

Thanks!

How are the airport/time capsules attached to the network?

If it’s via Routing, Broadcast & Multicast won’t be propagated across the router.

You’ll either need to set up a multicast repeater, or configure your ZeroTier network onto the LAN so that both the physical network & ZeroTier network share the same address space.

https://zerotier.atlassian.net/wiki/spaces/SD/pages/193134593/One+Port+Linux+Bridge

They are all on the same lan.

Let me explain:

Modem : 192.168.0.1

Router (as dmz host) : 192.168.4.1 (also dhcp server)

Timecapsule: 192.168.4.100
Raspberry pi running zerotier: 192.168.4.200
……
Wifi devices all on 192.168.4.x

Hope thats clear enough? :wink:

OK, but your ZeroTier network (the one I can see on https://my.zerotier.com associated with your account) is not in the 192.168.4.0/24 address space, nor is it bridged into your LAN address space. It’s routed from the ZeroTier network to your 192.168.4.0/24 address space via the netgear router. Broadcast & multicast will not traverse router boundaries and that’s a tcp/ip bugfeature.

Thanks for pointing that out.

I’m not sure what an actionable item is here. Are you suggesting i bridge the network somehow? I’ve tried many times to check the “bridge ethernet” checkbox but that did nothing useful in this case.

I have no emotional attachment to my lan config and in fact spent the last two days reconfiguring everything from scratch to try and get this to work. So anything goes. :slight_smile:

What would you suggest in this case?

I posted a link above that shows how to do network bridging with a Raspberry Pi. It’s more involved than just hitting the “bridge” checkbox on a node.

1 Like

Thanks, somehow that link didnt register in my brain :slight_smile:
I’ll go try that out now!!

Bridging is pretty involved to set up.

I had this setup for a while, but my mac kept trying to do time machine backups from remote locations and it wasn’t what I wanted.