"waiting for ZeroTier system service"

hi, i’ve been trying to open the desktop ui for zerotier for hours now. I have the latest version 1.8.4), the service is running, but when i click on the tray icon i got only 1 option : quit zerotier ui. The other option is greyed out so i can’t click it and it’s saying “waiting for ZeroTier system service”.

I’ve checked my firewall and all the rules are accepted and the ports are ok, nothing is blocking anything. i’m clueless at this point so i need help please. ty

same
replay install also

A couple people have said this. Haven’t reproduced it yet.
Can you go into the system services and see what the zerotier service says, and restart it?

1 Like

it’s currently running right now with automatic startup type. I’ve tried several times to restart it, uninstall/reinstall Zerotier completely, restart the computer, try different versions (ive tried two : 1.8.3 and 1.8.1) and it still tells me “waiting for zerotier system service”

Can you check if you have a C:\Users$username\AppData\Local\ZeroTier and an authtoken.secret inside. Does your user have access to read authtoken.secret? Thanks

1 Like

there is indeed an authtoken.secret file inside that folder. I don’t know about access to read that file but i would guess yes i have access since zerotier used to work in the past and i only ever had this one admin account. i had 1.8.1 when it was working a couple weeks ago but then i updated and suddenly i can’t make it work. :,( but ty for your time btw

Double click it and see if it can open in notepad.
Does the token match what’s in C:\ProgramData\ZeroTier\One\authtoken.secret ?
You could try deleting the userdata\zerotier folder and re-running the installer.

Sorry for the trouble. I tried installing 1.8.1 then 1.8.4 and can’t reproduce so far.

1 Like

I can open the authtoken.secret in appdata but I cannot open it in programdata. On notepad++. It says :
ERROR Can not open file “C:\ProgramData\ZeroTier\One\authtoken.secret”. And by userdata, do you mean the programdata folder? bc idk where to find a userdata folder.

Sorry, I meant AppData. Haven’t used Windows in a long time.

The one in program files has stricter permissions. You need open it as Admin, however that works.

Anyways. Please try to exit the tray app, delete AppData\Local\ZeroTier, then run the installer again.

2 Likes

ok so i managed to make it work. It was, surprise surprise, a permission problem.

so what i did was :

  1. right click the zerotier folder in ProgramData and select properties
  2. in the Security tab, click on advanced and select “enable inheritance”.
  3. then i closed the ui and deleted the folder in appdata like you told me (i prob didn’t need to do this but just in case)
  4. i stopped the zerotier service and proceeded to reinstall Zerotier.
  5. i re-enabled the service after installation and voila, it worked.

ty Travis for your time and guidance <3 i hope this will also help other people with the same problem.

Awesome! Thanks.

Now we just need to figure out how it got in that state, or how to automatically recover from it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.