WD MyCloud OS5 download

I’m attempting to install ZeroTier on my WD MyCloud EX4100. When I click on the link to download the file, I get a 404 error. Am I missing something here? I can’t seem to find anything.


Now is ready for download but in my WD with OS 5 when I try to install say that the package is incorrect

Which model do you have and what package did you try?

I have personal cloud mirror 4 tb, I tried with the package mirror , but when not works I tried all packages and no one works.

I tried other app (elephant) with the mirror package and installs perfectly.

But the zerotier package says wrong package

Is your MyCloud Mirror Gen 1 or 2?

it has actualizated to the last os 5.
p/n WDBCTL0030HWT-10 so its gen 2

That appears to be a WDCloud (not mirror). I’ve added a new package WDCloud_zerotier_1.8.4.bin, please try it: download.zerotier.com/RELEASES/1.8.4/dist/wd/

1 Like

it fails, not say the same message, the message before were “its not a correct package”, but with this new package continues failing the installation.

someone has the same problem and can help me please.
I really want to connect my nas to zerotier.

I have the same problem, I have the wdcloud and the others packs give me incorrect package and this gives error instalation.
Which is the problem?

This package works! I had to do a reboot on my WD MyCloud EX4100, but it now works!

I did a reboot several times, and nothing to do. perhaps works for your model, but in the wdcloud version doesnt work

Those models are completely different. I think he meant “this package” as in “this version of the EX 4100 package”.

Your model requires a build specifically for a Marvell Armada 375 chip. I am going to try to add that to our build pipeline next week.

1 Like

that’s would be great
thanks very much

I wait anxious that package.
thanks very much.

I used the link on this thread from zt-joseph. I downloaded the package for the WD MyCloud EX4100, installed it as a manual app. I then sshed into the MyCloud and ran the zerotier-cli join command, put in my zerotier network id. It didn’t od anything at first. I then rebooted the NAS and it started to work.

zt-joseph explain it very clear. In that link there is the correct package for your version of WDcloud.
For mine is not compiled the correct package , thats why for you run correctly and not for mine.

1 Like

any notices about the version?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.