[Win10] Bug in ZeroTier msi-installer

When I install msi-file, it requests Admin rights
But I have as error: “Called RunScript when not marked in progress”

Maybe there is problems with time of request Admin rights, idk…

Workaround:

  1. Run Command Prompt or PowerShell AS ADMIN!
  2. Process command:
    msiexec /i “D:/pathToYourFolder/ZeroTier One.msi”
  3. Install done without errors

Had the same problem.
Above solution worked for install, but I need to run as ADMIN whenever i start the program.

When started and I try and enter control panel, it is blank, and I get a message that something EDGE can’t acces some temp folder (sorry, don’t have exact message). I then browsed the user/…/appdata/ folder, and file explorer needed to grant permission to access that folder. From then on, I get a blank control panel but no error message. The temp folder the program tried to access i think is appdata/local/temp/zt_desktop_ui_[5-letter username]/EBWebView.

I occasionally have the same issue and use the same workaround.

I’ve now scripted it to run via our management systems which also works.

(When it’s working properly) the installer copies authtoken.secret to the installing user’s home. Then the tray app checks there, so the user doesn’t need to be admin. You could try to copy it manually.
I don’t know exactly where these map to:

local dir → Environment.SpecialFolder.LocalApplicationData) + “\ZeroTier\One”;
system → Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData) + “\ZeroTier\One”;