Windows client connecting to Linux Minecraft server gets stuck on "Joining world..." and times out

  1. Server is a QEMU VM running Ubuntu 18.04.6, ZeroTier 1.8.1, and a PaperMC 1.17.1 server.
  2. Client is running a fresh installation of Windows 10 Education x64, ZeroTier 1.8.4.
  3. Both the server and the client can ping each other, and communicate with each other in various ways. (i.e. SSH, HTTP server, etc.)
  4. Server is located in Minsk, Belarus; client is located in New Jersey, USA.
  5. Both computers say that “tcpFallbackActive” is false.
  6. Hamachi suffers the same issue.

A strange thing I noticed as well:

  • Linux server → Windows client = FAIL
  • Linux server → Linux client = OK
  • Windows server → Linux client = OK
  • Windows server → Windows client = OK

This is a very confusing issue, as Minecraft is the only game that suffers problems (to my knowledge.)

We talked a little on the subreddit.
It’s probably just a latency thing. Minsk to New Jersey…
Maybe there are some minecraft specific settings to make it handle latency better. I’m not familiar enough.

zerotier-cli peers on the windows machine says “direct” for the server node?

Yep.

6bxxxxxx3b 1.8.4  LEAF     276 DIRECT 2082     2082     [actual server ip]/29832

Try setting the interface priority to something low like “5” on the zerotier adapter.

Probably won’t help, but is commonly needed for windows games.

Tried it, no luck.

Just wondering, should I try changing the MTU value, or keep it at 2800?

Hmm. Many many people use this to play minecraft and don’t need to do that. I’m not sure. It doesn’t hurt to try I guess.

Bump, nothing seems to have worked. I have a hunch that it just might be my internet, because this is solely a me issue, no one in my group has the same problem, even with the same ISP. Also, Terraria doesn’t work as well, it just gets stuck at “Receiving tile data: 6%”