Windows RDP problem


Earlier today I connected to my server at my parents place. I connected my laptop to my mobile network did then RDP to my server from an outside network that worked great then.

But when I got back to my place and did an RDP It rarely connects. When I ping I get bytes received but I also get timed out. I think something is up with zerotier. A couple of days ago it was also working great from my place.

RDP seems to be sensitive to latency. You may not have a direct connection to your parents place for some reason.

On Sunday my connection worked great and it had been that for many days, I have never had a problem with latency. But later during this Sunday the connection started to get worse. I am also running a vpn at my parents place, and I am also running vpn myself. Something new must have happened since this Sunday, I myself have tried without running a vpn also but it makes no difference. Again I don’t quite understand it because everything had been working great for a while. When I am at my parents place I will try out what you suggested.

It also keeps on saying securing remote connection when I try and connect. Then it eventually connects but its extremely slow I have the experience on high speed broadband.

Its working now and the connection is a lot faster now I don’t get it.

This topic was automatically closed after 14 days. New replies are no longer allowed.