Zero Tier UI unavailable on Mac Ventura

So I have tried un install - re install - zero tier is running and connected but there is no way into the UI.

Mac OS latest version 1.10.6

The normal ZT icon on top bar is missing and have removed other items so there is space for it.

As part of de-install re-install - tried the pkg in other folders than the download folder (desktop / applications) and still no different.

This seems to have been reported quite a bit on here but the threads closed with no solution that I have seen.

Any help guidnace or confirm its an issue yet to be fixed would be much appreciated

Are you sure the is running? There are 2 parts to ZeroTier. There’s the zerotier-one service that runs in the background, and which is the UI. Make sure both are actually running.

“ZeroTier” App is showing running in Activity monitor.

If I log into my zerotier web account I can see the device as active in last 1min

Also the device can connect to other devices on the ZT network.

No errors from the installer or when you start the Program in the Application folder.

I’d try an app like Hidden Bar (free) or Bartender ($16). One of these seem to be necessary as the space for menu bar apps seems to be limited these days.

Thanks for the quick response.

Yes I have seen this answer before.

I installed hidden bar - no sign of the zero tier icon to move around / bring into view.

To further test I have turned off all other app icons - google drive / malware bytes / synology drive sync etc etc - made lots of space and no sign of the zero tier option.

If I turn the above back on - then they do show. Did this test to also prove a) there is space for the icon and also b) that other apps that run and place shortcust in the top bar are functioning as expected.

That’s really strange. My only other suggestion is to kill the via activity manager and try to restart it. Other than what I’ve already suggested, I have no clue as to what could be causing what you’re seeing.

Thanks, have tried that, and no difference.

ZT is basically working fine but with zero access to the UI.

Do other Mac users (M2 Mac running Ventura) have similar issues???

1 Like

Not that we’ve heard of. The only issue we’ve seen thus far was with the number of items on the menu bar causing the menu bar icon to be hidden.

Is there more diagnostics or things I can check / report back to assist with helping you find a fix??

I have this problem now too. I just upgraded to a Silicon Mac from an Intel one. Both were running ZeroTier under McOS 13.5.1. On the Intel one everything ran normally with the UI accessible from a menu bar icon. Under the Silicon Mac the menu bar icon has disappeared, yet Actvitiy Monitor claims that both parts of ZeroTier are up and running. I have tried uninstalling and reinstalling the app. several times to no avail. Any solutions ?

It seems like others are facing a similar problem with the ZeroTier UI being unavailable on Mac Ventura.
The discussion here has provided some insights into potential solutions and workarounds, which is incredibly helpful. Thanks!

I have encountered the same problem. My mac is M1 silicon. Have you solved it yet?

I temporarily use zerotier-cli. It works well

I’ve just installed v1.12.2 on my MBPro (M1 Pro, Ventura 13.5.2).
ZT installs, I try and run the application and the menu bar icon appears for a few seconds then disappears. I ran it again to see what options were available when clicked, and it just showed ‘Waiting for ZeroTier system service…’ and then closed after a few seconds.
ZT is not running in Activity Monitor.
I have quit other applications to make room in the menu bar, same issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.