ZeroNSD acting up

So in my ZT network I have a main “server” that runs zeronsd and a bunch of services (eg gitlab)
so I assigned to it different IPs and used non ZT records to point to each ip with a different name
(eg = git.beyond.corp)
problem is recently its been acting up and not working, how can I fix this?
I really need to be able to assign different names to these different IPs but going the normal ZeroNSD way doesn’t seem to work

Can you explain a little more about why that node needs many different IP addresses?

I don’t think ZeroNSD needs to listen on more than one of them. The dns server config in the network only needs one address.

You can use the hosts file feature of zeronsd to add more records.

The node needs multiple IPs because I’m running multiple instances of the same service (eg web servers) and since those all bind the same ports, they cannot run on the same ip

Do you think Virtual Hosting using the http header could be an option? Then you only need one ip for the web server.

Or just a load balancer in front of the services

I dont think its an option, GitLab especially is very specific about the way its hosted

Looks like GitLab supports load balancers just fine per their docs: Load Balancer for multi-node GitLab | GitLab

yeah there are many ways to go about it.

can you run zeronsd on a different node? maybe in a docker or vm. then it won’t try to bind to and configure all those ip addresses.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.