ZeroTier 1.14.0-2 can't establish vpn connection on Samsung S10e

I can connect to the network, it says online at the bottom but the key symbol (indicating vpn connection) doesn’t appear on my notification bar and as soon as I tab out of the app my connection is lost(it stays online as long as I am in app).I checked older posts on both this forum and github. I found that some vpn apps might be interfering with zerotier so i checked the vpn profiles for always-on option and i saw that none of them had that option turned on. Then I tested it with all vpn profiles deleted just to make sure, it asked for vpn connection permission again since I removed zerotiers vpn profile too. I accepted it but it still didn’t work, tried different versions such as 1.8.6 and 1.12, tried to disable ipv6, tried network dns even though i am using no dns, tried rebooting throughout the changes i made but they all have the same problem.

Phone: Samsung Galaxy S10e
OS: Android 11
ZeroTier Version: Both are 1.14.0
Usage Purpose: Windows Remote Desktop Connection