Zerotier Android client keeps disconnecting

The Zerotier Android client keeps disconnecting on wifi and data after a recent update to the VPN app from the Play Store. This is happening on ALL my connected devices and it’s becoming a pain. Is there any resolution?

Mine will not connect unless I change the configuration to Network DNS.
It then connects for a while

Bumping this since I don’t want this to die. Ever since the last update it seems that the connection can’t stay alive for more than a minute. App is straight up not working.

Similar problem: app disconnect and reconnect constantly.

Same issue here, ZT keeps disconnecting from network when I shift out of the app. New update 1.10.4-2(14th March 2023). installed but does not fix issue. This issue has only occurred since previous (early March) app update

Bump … having same issue with client android device

Never had this problem before, but after an update either android or ZT this issue has appeared.
i have to open the app and reconnect manually. happens when LTE signal is lost for a lil while it seems. will attempt to recreate the issue under controlled env.

Both mine and my wifes android phones keep disconnecting moments after connecting.

The latest versions on Android simply don’t work for me. Thankfully ZeroTier have earlier versions that can be downloaded from their website. Look on the ZeroTier download page and scroll down to “Older versions of ZeroTier can be found here”, choose an earlier version and then download the .apk. I’ve gone back to 1.8.6-1 and it works perfectly. Then within Google Play designate it not to auto update. Hopefully ZeroTier will get their latest updates to work on Android at some point.

Android v10.10.5 won’t stay connected. I am able to connect and keep connected for a while by turning off wi-fi and turning on ZT using mobile data. Finally turn wi-fi back on. Sounds like the problem is being worked on, not sure how to load an earlier version.

Same here, the new Android version constantly loses connection and then must be manually connected.

Bran new with putting app on android.
Been driving me crazy. Will downgrade to older app until this gets fixed.

How does one download and install an older version of the app?

Having the same issues with a chromebook. As of tonight, the VPN connection via the Android app no longer works with Zerotier at all. Previously, there have been no issues with setting Zerotier up as a VPN connection, in some cases keeping it set as an always-on VPN. Now, if the app is kept open, it will stay on-line - but no vpn connection is shown. Android client 1.10.5-3; Android 11 on Chrome-os 111.0.5563.71;

Not sure if it helps or not. Like all I have been having issues with the latest version of the ZT app, 1.10.3 onwards, specifically on Android 12. I have found that the latest version 1.10.5-3 works and is stable. However I had to re-create my ZT networks and re-join all my devices to the appropriate networks to make it so. This may not work for all, but I would suggest giving it a go

We have more then 30 tablets in a ZT network, all on version 1.8.x and waiting for a stable 1.10 version.

I tested version 1.10.5-3 but this version is still not working. We will be waiting…

Quick note on this. In the settings of the andoid app, I checked the “Disable IPv6” (then turned off phones wifi and back on, then reconnected the vpn) button and have had much less issues since.

1 Like

Tried above procedure and it works. Thanks @MostHated

You can uninstall your current version. Then from your browser on your phone you can download the latest 1.8.9 directly from Zerotier bypassing the Google Store:

You’ll have to rejoin to the networks again after downgrading to this one.

I am also having a disconnect issue, but mine seems to be different than what I am seeing in this thread.
I have a Samsung Galaxy S21 with all updates current and my ZT client is V 1.10.6-2.
This problem can be reproduced and it is associated with Google Cloud Backup. My testing method is as follows:

Verify that ZT is connected and I can access by Blue Iris cameras.
Backup my phone using the Samsung backup app.
Verify that ZT is still working (it is).
Backup my phone using Google Cloud backup.
Now ZT says it is disconnected and the status is offline.
I can turn it on by pressing the greyed out on icon. It immediately goes green and status is online.

I have been consistently able to reproduce this problem.
Everything seems to be working OK except when it does a Google backup (but the Samsung backup works OK).
Now that I know what the issue is, it is easy for me to just turn ZT back on again, perhaps this will help someone else out there.