Zerotier blocking mdns avahi service


I have installed zerotier on one raspberry exposing an avahi service discovery. Once zerotier is running , the service cannot be discovered anymore by other local area network devices. These devices have no zerotier installed (they are iot devices, it is not possible to install zerotier on them)

Someone can help?

Thanks a lot,


as additional information, my raspberry (running zerotier) is connected on the home router using ipv4 :
while the iot devices are connected to the raspberry using ipv6 :

I have tried to configure a route following the " Route between ZeroTier and Physical Networks" instructions page, with fd00::/8 as destination address (which is the subnet of my iot ipv6 devices) without any success…

Is there any way to “exclude” wpan0 interface from the zerotier vpn ?

Thanks for any help

zerotier just adds addresses and routers. not sure what avahi is going to decide to do when it sees them.

check out /etc/avahi/avahi-daemon.conf
maybe use allow-interfaces:

do you want mdns only on wpan0 subnet, zerotier subnet, or both?


Thanks for your answer,

I will check the cfg of avahi but ideally, i only want to advertize on wpan0


the avahi-daemon config was conf as default, without specifying any interface. That means that avahi will advertize on all local interfaces “unless point-to-point” interfaces, which is the case of the wpan0 one.

So, I changed the settings of the daemon, adding wpan0 on the allow-interfaces param.

I also changed the point-to-point option to “yes”

Rebooted the pi, but no change… :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.