ZeroTier Blocks Local Network

This only happens on my Android tablet. All other devices are fine.

When ZeroTier is turned on, I can only access my devices using the ZeroTier IP addresses. I cannot access the devices using my local network IP addresses.

I cannot find any additional settings in the Android app to fix this.

Anybody can help? Thank you.

In the app, instead of clicking on the toggle to turn ZeroTier on/off, click anywhere else in the box. That will open up information about the network. Toward the bottom, there is a checkbox. If it’s checked, it’s telling the network to route all packets via ZeroTier, and if that’s the case, your local network should be invisible, like you describe.

Unfortunately, it it’s not checked, then I don’t know what’s happening to you.

I really like an app called Ping&Net which will give you tons of info about your network setup.

Thank you. The box is UN-checked.

Also, there is an item for “bridging” and it says “disabled”. I don’t know whether this is the cause and I see no way to fix it.

I think the bridging is controlled by the controller at the ZeroTier website. If I’m wrong, then the only way to change anything other than the checkbox is to delete the network and add it again. There’s no danger in doing that, as the node id for the phone doesn’t change, and you automatically reconnect once you put in the network ID again, but you get to select a few other things when you create the network.

Yes, I think bridging is controlled at ZeroTier. Since all of my other devices work interchangeably with either local or ZT IP addresses, I’m not inclined to mess with the ZT settings on the website.

I will try deleting and reinstalling the ZT app on Android.

I may be too late in catching you with this, but you don’t need to delete the app (at least not to begin with). You can just delete the network, and then add it right back, which will allow you to see any other options that you might not have set the first time around.

OK, went down a rabbit hole of trying things, but still no joy. Played with DNS settings but back to original no DNS.

Interesting:

Delete network, close and open app. Network still there.
Delete network, close app and force quit app. Network appears to be gone.
Then delete app and reinstall app. Open app and network is still there. It doesn’t truly go away.

Wow, I don’t think I’ve seen that behavior with deleting a network and it reappearing. I can’t imagine how, but I wonder if that’s related to your problem on this tablet…

I still suggest installed Ping&Net. Once you launch it, it will give you a bunch of buttons. 1/2 down the right hand column is “Network Info”. Press that, and it should show you all of the network adapters (including virtual ones like ZT) and all of the routing tables, so you can see what’s supposed to go where.

I’m not strong on routing. But with ZT off, traffic routes through wlan0. And with ZT on, all traffic including local routes through tun0. Not sure how to change that.

That shouldn’t happen (at least not in my understanding) unless the box is checked for “via ZeroTier”, which you verified wasn’t checked.

That’s why I suggested Ping&Net, which would show you what was expected to be routed. That doesn’t mean it wouldn’t fail for some other reason, but at least you’d know whether the routes were even set up correctly to begin with.

Thank you. Yes, I used Ping&Net to discover that everything is routed through ZT when it is on. And the “via Zerotier” is UN-checked. But, how can I be sure of anything if the damned thing won’t actually delete!

Yes, that’s a head scratcher… I guess you could try to delete the network, then go into the Settings->Apps, find ZeroTier, force stop the app, then clear cache and data. I don’t see how it could retain anything then.

You would almost definitely need to authorize the device again in the portal.

Just out of curiosity, are you toggling the ZeroTier connection off before deleting the network? It shouldn’t make a difference, but perhaps that’s causing it to stick (if it’s still on somehow).

I have tried deleting the network with ZT turned on and off, both. When I tap “Delete”, it remains visible in ZT until I force quit or restart the tablet.

I just deleted the network. Force quit the app. Cleared data. Deleted the app. Restarted the tablet. Installed the app. And the network still appears.

Wow. I’m at a complete loss. Sorry!

Well, I got it to disappear. The tablet makes automatic backups and appears to restore the settings of an app if it gets reinstalled. I turned off backups and deleted everything and reinstalled the app. It appeared fresh.

But the routing did not get fixed. I have workarounds. Where I can, I have multiple configurations of apps that I can switch. For browsing, I have bookmarks for both LAN and ZT. It is just a pain.

At least one mystery is solved. Perhaps someone more knowledgeable than me will weigh in on the original problem! Good luck.

OK, I got it. There was an extra routing definition in my profile on the ZT website. Removing this and the Android now works. None of the other devices cared about the definition.

The extra definition was a remnant of trying the T-Mobile 5G Home Internet a year ago. The service is great and I can see the 5G tower from my home. But there is a major flaw with it. The modem/router device. It tended to overheat and drop the connection. Often only from 5G back to 4G. I had setup a timer to reboot the device hourly to get it to reconnect to 5G. Others pointed fans at it. Also, the router part had almost no routing functions. No IP forwarding. No UPnP. So devices on your LAN could not be exposed to the internet so you could access them remotely. Some people had successfully used ZT to get around this. I was unsuccessful.

Although the Verizon 5G Home Internet is not in my area, I found its specs online and the device seems to provide full routing capability.

Excellent, and thanks for updating the post! Yeah, I heard that port forwarding isn’t allowed on the TMo Home Internet.