Zerotier-cli status: OFFLINE

Hello, I’m using Zerotier on 2 computers that stay powered on 24/7 under Windows 10 and Kali Linux. both after one month of working the program stops working forever and says that status is OFFLINE. Reinstalling application not solves the problem. Only way is formatting all system and reinstall ZeroTier and it works again. Is there a solution for this?

This is likely a variant of this issue:

Your router is likely deciding ZeroTier’s traffic is malicious for some reason and blocking its communication.

My router always have firewall disabled.

Please read the entire linked post. If the suggested workaround doesn’t work, then it’s possible you have a different issue. It sounds very much like the same thing though.

Could you post the compiled version of the dev branch for Windows?

Not at this time. It’s not quite ready for release yet.

I’ve just downloaded Visual Studio, can i give it a try? If secondary & tertiary ports completely randomized on startup it could be almost enough for me.

As noted in the post linked above, you can manually set them via config file for the time being until the next release.

where can i check it’s using the secondary port i set in local.conf?

I don’t think that information is displayed anywhere, other than perhaps examining the output of netstat

 netstat -nq -p udp -b

would show each UDP port being used by executable name. (Windows only for these command line options)

zerotier-cli dump doesn’t show a different primary port even if i created local.conf in C:\ProgramData\ZeroTier\One specifying port 9994


“settings”: {
“primaryPort”: 9994,
“secondaryPort”: 21224,
“tertiaryPort”: 12458

You also have to restart the ZeroTier service

i rebooted windows actually
Which version should i run? i have 1.6.4

1 Like

If you created the file with notepad, it’s likely actually named local.conf.txt and the .txt is hidden from you by default in explorer. Just ran into that issue myself. You may have to drop to an administrator command prompt to rename the file to local.conf correctly.

yeah, same oversight here…Thanks for the support!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.