Zerotier-cli says that my device is offline after successfully joining

I have a NAS running on my Raspberry Pi on my home network. I set up ZeroTier to be able to access it from outside my home. I was able to successfully do so but later it stopped working.

redacted@raspberrypi:~$ sudo zerotier-cli join db64858fed2a9346
200 join OK
redacted@raspberrypi:~$ sudo zerotier-cli  info
200 info d41fb10a00 1.10.2 OFFLINE

In this post and the linked post it says that the culprit is my router. I tried following the steps to fix the issue by setting the secondaryPort in the /var/lib/zerotier-one/local.conf file but that didn’t help.

I have an ATT broadband connection and my router is BGW210-700. Here are the firewall settings.

|Packet Filter|On|
|IP Passthrough|Off|
|NAT Default Server|Off|
|Firewall Advanced|On|

and here are the advanced firewall settings

image

I haven’t made any modifications to the default settings. Do I need to make any changes to the router settings to be able to access my Pi from outside my home network?

I just had a case where two devices seemed to be “off”. The one (a Mac) was a case of the zerotier had to be started/connected to the network, but the other, a RaspberryPi that had a 10minute network (Guess firewall/router restart), is the puzzling one - restarted, stop-started zerotier, even rebooted the RPi, but still no conenction to the “planet/world”, even though it’s “connected” according to itself and UDP packets flowing in both directions to the planet/root servers, but no traffic between it and the rest of the network, and the “controller” showing it not connected.

The RPi was not seeing any received traffic, but was sending traffic. PEERS even seems to be “coinnected”, but no data seemed to be travelling.

What “fixed” it was to deorbit and re-orbit the moons I’m using for local (ZA) traffic