ZeroTier control center auto-assign IPv6 with unique range

Hi everybody,

I’m new to ZeroTier, but excited about it. I’ve looked at the forums, and I’m not seeing this question get addressed.

I have a rather unique IPv6 application. I want to assign an address in an IPv6 /96 ULA subnet to each of my devices.
For example, that might look like: fd00:aaaa:bbbb:cccc:dddd:eeee:ffff:1234/96

I tried putting my particular ULA in the auto-assign area in the network control center GUI, but it doesn’t auto-assign my devices an address from this pool.

It does auto-assign the zerotier interface an address from the other two pools (RFC4193 and 6PLANE). Those seem to work fine and I can ping and ssh between them using these addresses. But when I define my own IPv6 address pool, it doesn’t assign the device an address from that pool. I am running linux on the ZeroTier devices, and I tried manually assigning IP addresses from my ULA to the ZT interface. That didn’t work.

I might be able to figure out how to make RFC4193 work for me, but my address scheme would be a lot simpler if I can simply define my own ULA pool beginning with ‘fd’.

I’m probably doing something silly. Thanks in advance for helping a newbie.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.