Zerotier difficulties with Ubuntu 20.10

Hi there,

I’m looking for some help please. I cannot get Zerotier to work when I try to start it. I used Zerotier before on Ubuntu but recently I upgraded to 20.10 and now I can’t seem to get it working. I’ve tried just about everything including reinstalling numerous times and building from source.

I think that one of the problems is that I’ve found it very difficult to find step by step instructions about installation on the new version of Ubuntu and the snap store has instructions that leads to installation of an older version.

I’ve tried working out what is going on but I’m stumped. When I run the systemctl status zerotier-one command it returns this:

● zerotier-one.service - ZeroTier One
Loaded: loaded (/lib/systemd/system/zerotier-one.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-03-26 16:18:59 GMT; 36min ago
Process: 3834 ExecStart=/usr/sbin/zerotier-one (code=exited, status=1/FAILURE)
Main PID: 3834 (code=exited, status=1/FAILURE)

Mar 26 16:18:59 my-computer systemd[1]: zerotier-one.service: Scheduled restart job, restart counter is at 5.
Mar 26 16:18:59 my-computer systemd[1]: Stopped ZeroTier One.
Mar 26 16:18:59 my-computer systemd[1]: zerotier-one.service: Start request repeated too quickly.
Mar 26 16:18:59 my-computer systemd[1]: zerotier-one.service: Failed with result ‘exit-code’.
Mar 26 16:18:59 my-computer systemd[1]: Failed to start ZeroTier One.

Any help with this would be very much appreciated.

Cheers.

Strangely, it now seems to be working. Something must have happened but no idea what. Anyway this issue can be closed.