Zerotier does not upgrade using apt upgrade on Debian Jessie

I’m running a VM using Debian Jessie, and found that the zerotier package will no longer upgrade.

I’m stuck with version 1.8.x, latest version is 1.10.x.

I noticed a similar topic discussion which was closed automatically without resolution: Zerotier - unifi cloudkey - debian jessie armhf update failure - #29 by n9yty

I’ve tried downloading the 1.10.x .deb file from the repo, but it won’t install either, giving the same error: zerotier-one : Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u2 is installed

Will this be fixed, or am I forced to upgrade from Debian Jessie?

Seems the last version I can upgrade to is 1.8.7, and the dependency error happens in 1.8.9.

All support for Debian Jessie ended back in June 2020, and that was for LTS:

So, you’ve not been getting security updates for three years, the Debian maintainers moved on long ago, and other software providers moved to support more recent versions. So, yes, you will need to upgrade to something supported.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.