ZeroTier doesn't work for NextCloud on Proxmox

Hy there. Please help.
I have an installation of NC on Proxmox (Ubuntu 23.04) as CT but i cannot access it from outside my network with ZeroTier on my phone or on my PC with the ip address shown in ZeroTier for my server.
I have ports 80 and 443 forwarded on my router and in Nextcloud.
I thought to put my problem in here first time because when i type “sudo zerotier-cli listnetworks” i get no network list. I get an answer (first line) but no second line.
I have had also problem with my (connection) “network card”. If i used to type ifconfig the ZeroTier network didn’t appear. I had to add manually that network, in Networks on NC and then was ok.
Thank you.

I’m a little confused as to what wouldn’t work…

Port forwarding is not needed when you try to connect to a host via Zerotier. That brings me to the question of where is Zerotier installed, on the Ubuntu host or Proxmox? It should be the Ubuntu host. What is the output from this command on your Ubuntu server:

sudo zerotier-cli peers

Did you connect your Ubuntu server to your Zerotier network with:

sudo zerotier-cli join <<networkID>>

Hy. Thank you for your answer.
I cannot access my NC thru my phone on the app or my PC if i try the ZeroTier IP, i receive no ping from the NC server thru the ZeroTier IP. I know that i don’t need port forwarding, but i try it anyway.

ZeroTier is installed on Ubuntu host where is the NC also installed, and NOT on Proxmox.
I connected my Ubuntu (is not on Ubuntu server) server with that command, yes. And my server appears on ZeroTier Central. See the attachments.
Thank you.

Aslo… should i be able to connect with ZeroTier if NC is on Proxmox?
See another attachment.

I’ve installed NC for at least 20 times. No exaggeration, I swear. I’ve tried it on Ubuntu 22, 23. On debian 11. Also with Turnkey-Nextcloud. All same result. I’ve followed different videos on YouTube. Can anyone point another way?
On local network all work flawless.

My real concern is when I run this command “sudo zerotier-cli listnetworks” is that it should return 2 lines. One with names/titles and the second one with the actual answer… ID’s, IP’s, network, etc. The second line doesn’t appear.

Thanks in advance.

The first two lines with the role LEAF are direct connections to two clients in your Zerotier network. You can check if the ztaddr are correct and also check if the ip-addresses in path are also correct.

Can you connect your Nextcloud with his local ip-address. Nextcloud has the configuration option ‘trusted domains’ in config.php where all ip-adresses and domains are listed that can be used to connect to your server.

See this for more details:

Thank you for your time.
I don’t know exactly what you mean about “You can check if the ztaddr are correct and also check if the ip-addresses in path are also correct.”, but I can tell that all the IP addresses and path’s are correct. I can also tell that when I tipe the ztaddr in nextcloud, after a while the NC answer is “server took to long to respond”, so I think that the IP address and the connection is ok, until reaches my server.
“trusted domains” are also set correct and, YES, with my local IP address I can connect flawlessly on my PC and/or Phone.
My question now is, if I have a local DNS server (pi-hole) has anything to do with my problem? I didn’t set any setting regard my DNS at NC installation. Should I change settings anywhere? Where? Should I have to make a domain in pi-hole?
Thanks allot!

It’s tricky to get zerotier running in a proxmox container. It’s been a while so I don’t remember the details, but it has to do with permissions and loading the tun module. ZeroTier needs to be able to create network interfaces.
You could try next cloud in a VM.
Or you can run ZeroTier on the host and route between zerotier and proxmox network from there.

Thank you very much for your answer.
Can you pretty please try to remember your steps or to point a place where I can find those steps?! Please !
Best regards !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.