ZeroTier issue *only* with Activision/Treyarch games

I’ve been using Zerotier to play LAN games w/ my friend for a while and its worked flawlessly except now with Call of Duty, specifically World at War and Black Ops. I host a game and my friend can’t see it. Zerotier’s worked fine with everything else we’ve tried to play but for some reason Call of Duty doesn’t like it.

Does anyone have any idea what might be wrong? I’m on Win10 LTSC 2021 with the latest updates. Any ideas would be appreciated.

Things I’ve tried: reinstall Zerotier, disable firewall/AV, reinstall game(s), port forwarding all the ports the game(s) use, turning on network discovery, setting a static IP, and having my friend ping my Zerotier IP (it does respond) and unchecking Automatic Metric and setting it to “1” (this was the fix for a previous game that initially didn’t work).

One more thing of note for World at War: when I change the game room settings (like map, max # of players, etc) my room shows up to my friend on the game’s server browser list. However, him trying to join results in an error message (game session no longer available) or it gets stuck “trying to join” indefinitely. The ping is also displayed as between 1500-2000ms whereas it’s usually under 100. Not sure what to make of this but it may help someone help me narrow it down.

I’ve been at this for a few days, a few hours a day. So any help is greatly appreciated!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.