Zerotier login error

i can’t login zt;o(╥﹏╥)o

1 Like

getting the same error. havent logged on in quite a while. reset my pw and now when i log in i get this…

Hmm… That definitely shouldn’t be happening. I’ll take a look.

I assumed it had something to do with the account changes in 2019…saw in the faq area something about it. not sure when the last time i logged in was but i know its been a while. might be completely unrelated though also.

I don’t think that’s related. I’m not sure what exactly is going on as of yet, but I’m still digging in.

If you delete all your cookies in your browser for * does the behavior change at all?

Just tried, I’m using chrome. Same error:

{“type”:“internal”,“message”:“Error processing OIDC login token exchange”}

Just tried on MS Edge which I never use and get the same error.

This is really weird. The auth server is failing the OIDC code to token exchange but I have no idea why yet. Nothing’s changed in that code path in quite some time.

Just thought to try it on my phone. Same exact error.

Emmm, my account login forum no problem, but login central can’t, my solution is to re register an account.

Still looking into this, and still not sure what the issue is.

Same error for me too. I tried to register using Github and it gave me that error while trying logging in on

Unable to login as well.

I used ZeroTier in the past a while ago, but cant login anymore because of the same error:

zerotier Error processing OIDC login token exchange

Is Zerotier still maintained?

1 Like

Yes it’s still maintained. No, we don’t know what the error is. It’s only affecting a very small subset of users and it’s not an error we can reproduce internally.

I’m working on an upgrade to our auth system to the latest version. It takes time, though.

Great! thanks for the quick update and glad to know it’s still maintained.

FYI, I have tried registering with a new email (using + alias on gmail) and got the same error.

We’ve tried that as well. Still can’t reproduce the error. Do you have any browser extensions running? Perhaps try disabling those & trying again.

Just upgraded a library used by Central that had a potential bug with not using UTC time for OIDC/OAuth2 processing.

@raphael.brugier @risusinf @Aster @dunnbeetle28 @wgq4812 : If any of you can give logging in a try again and let me know if it works, it would be much appreciated.

Still getting the same error here. It’s not pressing on my end for anything. Just saw a post on it so figured I’d let people know it was happening to me also. Thanks for looking into it.

No changes on my end.

Still happening for me. Even with in incognito mode and no extension.

One thing to try to reproduce:
I registered with my email (@ gmail account) awhile ago .
When I came back yesterday, I forgot I had registered using email and clicked the “login with Google” button. It failed and since then, both login with google or login with email fail.