Zerotier+Macos+cloudflare problem

I am unable to connect to zerotier (stuck at ‘requesting configuration’), when I am connected to cloudflare warp at the same time.

However, I have no issues with Zerotier+Clouflare Warp+ Windows. I even see the cloudflare ip address for the windows client in the Zerotier Dashboard, so it doesnt look like a nat issue.

I have the same issues on a 2017 27 inch imac and an M1 Macbook air.

What is interesting though, is that it ‘seemed’ to work for a few hours on the imac, when the Zerotier control panel status showed “Tunneled” rather than “Online”. I don’t know how that happened.
So tried bouncing the cloudflare warp connection and it stopped working again.

Since then, I occasionally see the status going to “Tunneled” for a while, but it never worked again

I tried adding the zerotier root server ips to the bypass list in cloudflare warp, to no avail.

Any ideas?

Ok, the problem seems to have been solved by configuring cloudflare warp to bypass (split tunnel) the zerotier public root server addresses.

I got the addresses by running zerotier-cli list peers, and choose the ‘PLANETS’.

Is there a complete list of the public root servers? So I can add them to the bypass list.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.