ZeroTier Minecraft Server Problem

Hello everyone! I have a problem with my minecraft server! My friends and I are connected to one another via ZeroTier, I am able to join my server with my IP, but my friends aren’t.
The error they are getting is “io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection timed out: no further information:”

I have tried updating Java, running “ipconfig/flushdns” and the following commands, but this didn’t seem to work, I have also tried redownloading ZeroTier, and creating a new network, but this didn’t work either.

However, when we are connected to one of my friend’s network, and playing on his server, everything works just fine and we are able to join the server, the problem is with my PC, and I’m not sure what to do, if anyone has any solution, please help! thanks in advance!

I’ve had the exact same error with my computer for a while and none of these solutions worked for me either…

It looks like the server is running on Windows. What version of Windows? Make sure Windows/Firewall thinks the zerotier network is a “private” network.

Hi! Its on Windows 11, and its actually on “Public” you were right, I also checked with my friend and his network which is working is on “Private”, I don’t understand how to change it to private tho?

ok I did it! and it works! thank you very much for your help!
the solution is here: Windows 11 does not prompt for Public/Private network (Windows Firewall setting) · Issue #1671 · zerotier/ZeroTierOne · GitHub