Zerotier says it's online but it can't connect to anything and central says it isn't online

I’m running fedora 36, installed zerotier using the install script from Download – ZeroTier (curl -s https://install.zerotier.com | sudo bash) and run it with sudo systemctl start zerotier-one

My problem is that zerotier seems to think and say that it works but it doesn’t. I can’t join any networks with sudo zerotier-cli join network, zerotier says that it succesfully joined (200 join OK) but it actually didn’t because I can’t see the node in central page and it even says it successfully joins if I input a network id that doesn’t even exist. I added the node manually in the central page and it says the node was never online, 0.0.0 version, physical IP unknown.

I tried disabling the firewall (sudo systemctl stop firewalld) to check if zerotier will work this way but it still doesn’t and I restart zerotier after everything I try to change (with sudo systemctl restart zerotier-one). I’m completely lost and don’t have a slightest idea of what the problem may be…