Zerotier service not working - remote access failing

Hi Everyone,

I have an Intel NUC that has Xubuntu installed on it (fully updated) and I have installed both zerotier and x2go server on it. Zerotier has been connected to my account and is showing online. When I try and use x2go client from another machine and connect to it remotely outside of my home, it just fails and doesn’t go through.

I know SSH works with x2go as it is working locally. I am new to linux but I have a strong tech background and can follow commands and steps to get something working if explained in detail. Any ideas on what to do?


Is ssh working over zerotier? can you ping your zerotier ip address from outside your home? How is the latency?

I tried doing a ping to the managed IP my device is assigned to and it failed.

SSH over zerotier isn’t working either.

can you ping the zerotier IP addresses when you’re on the same physical network?

Can you double check the output of sudo zerotier-cli listnetworks and sudo zerotier-cli info on the pi for anything suspicious?

Ok my devices connected to the service can indeed ping the zerotier IP address assigned to it.

I haven’t turned on my pi in weeks as you can tell. I care mainly more for my NUC than anything else. It shows that it is online and indeed joined to the zerotier network.

The pi and the nuc are the only two devices I see on your network. Was there a third device? It needs to be authorized on the network too :slight_smile:

No I don’t have another device. Nuc is the only one I am interested in right now.

Anything I can do to start connecting to the service from the outside world?

Whatever machine you’re attempting to connect to the NUC from has to have ZeroTier installed on it & be joined and authorized on the same network.

Wait so if I use a windows machine (use work for example), it has to be part of the zerotier network to connect?

Yes. Both ends of the connection must be joined to a ZeroTier network for you to be able to communicate over ZeroTier


Worked like a charm. Thanks

This topic was automatically closed after 14 days. New replies are no longer allowed.