Zerotier service shutting down

For some reason the Zerotier service close just after starts, sometimes it keep some few seconds then close it again… and I can see, it started, in the zerotier control panel it was even a assigned ip for some few seconds

I really feel it strange how Zerotier show no error anywhere and didn’t log anything where I can see, therefore I’m completely lost.
I tried look in the windows event log and I can see this error information…

Where the exception code 0xc0000005 seems to be “Access Violation”

What I tried

  • reinstall the Zerotier
  • use older version
  • delete the authtoken.secret file
  • join in the room by CLI
  • Firewall/Win Defender completly disabled

My Setup:

  • Acer Nitro 5 AN517
  • Intel i5-9300H CPU
  • gtx 1650 4GB
  • 24GB ram
  • 5ghz Wifi
  • Windows 11

When I’m out of any room the service don’t ‘cash’ and keep running fine, just useless if I’m out of any room.

After a self debug, I find the exception to happen in this line 114

due this function contains this line:

strcpy((char *)v13, "SYSTEM\\CurrentControlSet\\Control\\Network\\{4D36E972-E325-11CE-BFC1-08002BE10318}\\");

I think the crash is near here:
ZeroTierOne/WindowsEthernetTap.cpp at dc54e0e1c4a0566deb6261291691f17d4220e08d · zerotier/ZeroTierOne (

I confirmed, since is just a function to set the friendly interface name I patching this jz with a jmp did the trick and now is working.
I’m going to report the issue in github since I had all the troble.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.