Zerotier setup fails after reboot when trying to forward all traffic through router

Hi all, currently I have the Brume 2 from gl.inet (OpenWRT) router with Zerotier installed, connected by an ethernet cable to my main home router. Bridge mode is enabled in Zeortier, with a managed IP address of 172.22.187.41. I’ve setup a managed route in Zerotier to be the following:

Destination: 0.0.0.0/0 via 172.22.187.41

I have ensured IPv4 forwarding is enabled, and set the following iptables configurations:
PHY_IFACE=eth0
ZT_IFACE=ztxxxxxxx

  • sudo iptables -t nat -A POSTROUTING -o $PHY_IFACE -j MASQUERADE
  • sudo iptables -A FORWARD -i $ZT_IFACE -o $PHY_IFACE -j ACCEPT
  • sudo iptables -A FORWARD -i $PHY_IFACE -o $ZT_IFACE -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

Here are my interface settings in the Brume

I have uninstalled mwan 3.

When I activates Zerotier on my iPhone with and check the IP address (with LTE data), I get my home IP address, so all is working correctly. However, once the I reboot the router, I lose the connection and I have no idea why. What I am trying to do is set the Brume 2 so I can route all traffic from other devices when I travel, and get my home IP.

Things to note:
1- My home router is behind CGNAT, so I don’t have a public IP address.
2- My ISP does not offer IPv6.

I am not good at networking and I appreciate any help you can give.
Thank you!

I managed to get t working. The issue is solved :pray: