ZeroTier with Windows Remote Desktop not working unless restart the computer

I have been using ZeroTier with Windows Remote Desktop Conneciton (RDP) for 6 months and everything is running fine. However, from time to time, I will say once a week, I can’t remote in unless I reboot the computer where I need to remote in.
Both computers are windows 10. So I have to use TeamViewer to remote in to reboot my office PC. Then I can remote using Windows Remote Desktop Connection (RDP).
I have tried to find the solution but I can’t seem to find it.
Anyone help?

I’m also having this issue, I have had it in on virtual machines and normal workstations. Restarting them seems the only way to resolve the issue. I have tried disabling the virtual adapter then reenabling and also tried restarting the service to no avail. I had to actually setup a restart task schedule on the VM’s, generally on my workstations they shutdown at night and restart in the morning so not an issue, its when they are left on it becomes and issue. Sorry not really a fix, but hopefully someone else might see this and contribute to help solve this issue.

Sorry we missed this.
Update everything involved to 1.6.5 if they aren’t already.
It sounds like something that happens behind certain routers/firewalls that we are working on better fixes for.

Hello @zt-travis,

I have kind of the same issue when I upgraded to 1.6.5. I reboot the pc and zerotier was not running. The service was not set to start automatically. I changed the service to automatic and still didn’t start on restart. I had to change it automatic (delay start) then it worked on reboot. This was on a Windows 2016 server, if that makes any difference.

When I use (RDP) with ZeroTier I get the error: “Internal error”.
Has it happened to you?

hello @ecruz,

I have never had RDP give me an “Internal error” when I have connected through Zerotier. If anything happens I don’t connect at all.

You might want to check the event log to see why that is happening. I am also not connecting to Windows 10 pc but to a Windows Remote Desktop Server.

Shane

Thanks for this note. It is supposed to start automatically. One other person has mentioned this recently.