Zerotier Won't Open on MacBook 14" M1

I’ve been trying to get Zerotier to work on a new MacBook M1 without success. The installation went fine but on opening the Zerotier client nothing happens. I’ve uninstalled and reinstalled several times and still no success.

Can anyone help diagnose why this is happening?

Edit: Just to clarify this is a personal MacBook with no third party firewalls etc. I also checked in settings under Automation and the Zerotier entry is ticked.

Out of interest, does the client talk to you if you use the terminal?

So, open the terminal app, then interrogate the status of zerotier as sudo:
sudo zerotier-cli status

If the graphical client doesn’t work, you can configure quite a lot just via this interface, it should be enough to get you going.

Just be aware, I had a lot of this happen to staff over this end with the M1 Macs, but I’m waiting for a working client. I’m pretty sure what is happening is that the authentication secret token is not being copied between accounts; so it’ll work for the first user who did the installation [site admin], but not the second.

Thanks for the reply. If I interrogate Zerotier in Terminal it appears to report online:

200 info xxxxxxxxx 1.10.1 ONLINE

I’m not familiar with configuring from Terminal so it would be really helpful to get the GUI up and running.

Thanks again for your help.

I think I tracked this down. Seems users experiencing this issue have an invalid copy of the local API authorization token

macOS fix:

  • Close the ZeroTier tray application
  • Open a terminal and execute the following command: rm ~/Library/Application\ Support/ZeroTier/One/authtoken.secret and possibly rm ~/Library/Application\ Support/ZeroTier/authtoken.secret as well
  • Reopen the ZeroTier UI application. You should be prompted for the administrator password so you can re-copy the authtoken into your user settings folder.

Windows:

  • Open Explorer and type: %LOCALAPPDATA%\ZeroTier\ into the location bar.
  • Remove authtoken.secret.
  • If a One subfolder exists, delete authtoken.secret from there as well.

Thanks for that info. Just before I try that can I ask about the ZeroTier tray application as I can’t see this running on my Mac. I assume the fact the ZeroTier client is running means the tray icon should be visible but it’s not.
Is there a command to close the tray application from Terminal?

If there’s no ZeroTier icon in the system tray, then the UI portion isn’t running. The background service is always running in the background though.

Thanks again for the reply.

I ran the two commands you suggested, the first said the file didn’t exist. The second actioned ok. However on opening ZeroTier again nothing happens and no GUI appears.

Any other suggestions?

The GUI doesn’t open a window. It’ just an icon on the top task bar
image

I have no icon in the top task bar unfortunately.

I don’t have a clue then. We have a few employees here on M1 macs and they aren’t experiencing what you’re describing. Try a reboot?

I’ve deleted the ZeroTier folder and also looked to see if any ZeroTier service is running. In activity monitor there is a service running called zerotier-one and whatever I do it won’t stop.


Any suggestions to kill this service and then I can try a reboot and reinstall.

https://zerotier.atlassian.net/wiki/spaces/SD/pages/736690190/Uninstall+ZeroTier+from+your+Mac

Thanks again.

I removed ZeroTier completely as per your link - many thanks for that. I then rebooted and installed ZeroTier again. After installation I opened the ZeroTier application and it asked for my password as it wanted to make changes. Did this but still no tray icon so I’m stumped as well.

Activity monitor shows the service and application running - very odd.

Ok solved the tray icon issue. It seems that if the menu bar has reached the maximum number of icons it can display then the others aren’t displayed at all and there’s no way, that I’ve found, to display the hidden ones. I simply removed several icons and the ZeroTier icon suddenly appeared.

Such a simple fix but not obvious to me anyway :man_shrugging: :person_facepalming:

1 Like

There is a great app called Bartender that will solve your “too many Menu Bar applets” issue.