(Android) Zerotier keep stop working after 1.10.3 update

New update again today, and still does not work. Had to downgrade to 1.8. Shame. This had such great potential and had been recommending for over a year. I certainly won’t be recommending this again any time soon. Fix it, or back out the “new feature” that’s causing the problem. Not a complicated solution.

Throwing another data point into the mix for problems with the update (including 1.10.3-3).
Nokia 6.2, Android 11.
Like others are (e.g. a21) describing, connection reverts to OFFLINE after a few minutes, despite the toggle switch being activated. At no time does the phone believe itself to be connected to a VPN, nor do I see my ZeroTier IP address in the list of addresses the phone’s network adaptor shows.

Same problems with Xiami Mi 6, Android 9, ZT 1.10.3-3

Another day another issue. Phone regularly notifying as Zerotier connection drops in and out. Driving me nuts. ZT 1.8.9 wasn’t bust. Stop “fixing” it ! I don’t know what this latest round of updates was supposed to improve but it’s failed miserably and sadly doing immense damage to your reputation. Zerotier was a game changer but you’ve dropped the ball and seem to be in the process of burying it. Just get it back to where we were ASAP.

1 Like

The current solution is to roll back to version 1.8.9 and reset the network to reset the connection. Try not to upgrade easily

Samsung s22 and ZT 1.10.3-3.
As suggested I’ve disabled IPv6 under SETTINGS in the app. After that the connection have been rock steady for more than 12h. Roamed various different wifi’s and cellular networks.


The same thing happened to me, from the mobile phone with Android it did not connect.


It seems that when updating it does not read the configuration that it had before.

Thinking back, I think it has already happened again.

I hope it works for you.

Good day.

Samsung S22 1.10.3-3 doesn’t work, either. IPv6 on/off doesn’t help. The key symbol in the android status bar disappeared as well even though zerotier says it’s connected.

Google Pixel 7, android 13, same issue’s as everyone else.

I have not had success toggling IPv6, but have had success setting the DNS to Network and then back to Custom.
But don’t disconnect once you’ve done that, else it will fail and you’ll have to do the DNS dance again.

Also same problem. ZeroTier worked great for the last 8 months, rev 1.10.3-3 breaks it.
Glad I found this thread.
Samsung Galaxy A53 5G, Android 13 .
Switching IPv6 off and on and off (trying intermediately) works most of the time.
But didn’t get 1.10.3-3 working when connected to LAN (only when connected to 4G).
Peculiar: Phone mentions 1.10.3-3, but ZeroTier Central mentions “ONLINE 1.10.4” .
Hope you can fix this, ZeroTier is great.

Galaxy Note 20 Ultra same issues. Toggle ipv6 will temporarily allow connection. But drops after some time and will have to toggle again. Same on wife’s phone (same phone).

ZT version 1.10.5-1 not working on Samsung tablet S4 (Android 10)

Updated to 1.10.5 on both of my Androids.
The older one is running Android 11 and ZT1 is working.
The newer device is running Android 12 and ZT1 not working.
I have to run version 1.8.6 on the device with Android 12.

updated to 1.10 5-1. still the issue remains however i can sidestep it by disabling and enabling ipv6 in settings

Toggling Ipv6 does not seem to help for me, what version of Android are you using @CountZero ? I think I have 12


Installed v1.10.5-2. Another complete fail on Android 12 Moto. I’ve had enough of this messing about. I shall be traveling for the next few weeks, need this to work so will go back to 1.8.6 to ensure links - and endeavour to avoid further updates. So no news from me will NOT mean problems solved.

This is such a sad and disappointing development!

same here @guru.gubbins , installed still same issue. I agree so disappointing. I use ZT a lot to access my resources remotely, and mainly from my phone. Like you going back to 1.8.6 for now. Hope it gets sorted soon though. Safe travels

Same issue. Android 13 on Pixel 7 Pro. I just installed this for the first time on 3/16/23, shortly after this issue apparently happened. Disabling and re-enabling IPv6 did get it to a working state again. Holding off on installing this on other family members phones until this issue is resolved. Off to a bad start, to say the least.

Same issue. Android Galaxy 10e. No key showing up the screen and cannot access my Blue Iris cameras with my phone anymore