Cannot connect to network controller, other devices can see each other

I have an ubuntu server running zerotier with ztncui. The server is controlling a ZT network where a few raspberry pis and laptops connect. All running fine for months. Yesterday the machine (I think) upgraded to ZT 1.8.1 and since then all the R-Pis and the laptops can connect to each other, but they cannot ping or ssh into the server. See screenshot. 250.10 is the server, the other machines are also on the 250 network


Have tried to recreate the network and all sorts of things, but the server can not be found with ping (destination host unreachable), even though it reports as being online and comes up on the ztncui interface…the other machines can ping each other

Appears similar to this one: Zerotier device show "green" but cant connect, ping fail
But I did reinstall zerotier-one and it didn’t help (I did not delete the identities, should I try that?)

Any ideas would be much appreciated!!
Have been wasting hours on this and cannot make progress. Thanks

Ok, I moved the network to another server and had the original server just as a member on the new zerotier network. Worked initially, then the server in question stopped working with the same problem today. So it being the controller and member of the same network wasn’t the issue. In the end I deleted the identity files in /var/lib/zerotier-one, rebooted and it worked from there on. Will monitor and see if it happens again… weird?

let us know what you find out