Can't communicate with joined network devices anymore after update

I updated from 1.8.9 to 1.10.1 recently on my ubuntu server vm.

$ hostnamectl
Static hostname: -
Icon name: computer-container
Chassis: container
Machine ID: -
Boot ID: -
Virtualization: openvz
Operating System: Ubuntu 20.04.4 LTS
Kernel: Linux 5.4.0
Architecture: x86-64

Since then it is no longer able to communicate with the other devices in the zerotier network it was part of.

I left and rejoined the network, joining fails with errorcode 500.

$sudo zerotier-cli -j join <newtworkid>
500 join {}

The device actually appears and updates on the management view - but it is not able to establish a connection to other devices in the network.

Uninstalling Zerotier (also removing /var/lib/zerotier) restarting, installing zerotier, restarting, joining network, did not resolve the issue.

$sudo apt-get remove zerotier-one
$rm -R /var/lib/zerotier-one
$shutdown -r now

$curl -s 'https://raw.githubusercontent.com/zerotier/ZeroTierOne/master/doc/contact%40zerotier.com.gpg' | gpg --import && \
if z=$(curl -s 'https://install.zerotier.com/' | gpg); then echo "$z" | sudo bash; fi
$shutdown -r now

$sudo zerotier-cli -j join <newtworkid>
500 join {}

Again the device appears with a different id on the management view, but is not able to reach/be reached by other devices.

I tried to add a different linux system to the network, that worked fine.

What I noticed while doing so is, that no new virtual network adapter gets created if I join a network with the troublesome system. So I assume the issue is caused by this.


What I need now, is a pointer what I can do to get zerotier working again, without reinstalling the whole system.

  • Is there a way to get more details on why the join fails - not just a “500”?

  • is there a way to uninstall zerotier more completely?

  • how does zerotier create his virtual adapters? Can I look into possible errors regarding this somewhere?

I was able to resolve the issue:

the command:

sudo systemctl status zerotier-one.service

also printed some error output. In my case it said:

ERROR: unable to configure virtual network port: could not open TUN/TAP device: No such file or directory

That pointed me in the right direction for my search with the solution being posted here:

The service needs to start “/usr/sbin/zerotier-one” with the “-U” parameter which was not the case for me. Now it works again.