Error relocating /usr/sbin/zerotier-one

Hello. I have Zerotier installed on my Docker host which is running the latest version of Alpine Linux. For some reason in the middle of the night last night my Alpine server stopped talking to the ZeroTier network. Looking at the services, it was running, and I’m able to restart it without error. However, if I call the zerotier-one command I get the following error:


I’ve tried restarting the service, uninstalling and re-installing it, so far nothing has fixed it. I’m using the package available in apk.

Any help is appreciated.

Alright, I got it to atleast run now by doing the following:

apk del zerotier-one

Then went into the repository list and removed the Edge repositories:

nano /etc/apk/repositories

Then ran

apk update && apk upgrade

apk add zerotier-one

From there I was able to start the Zerotier service and join the Zerotier network. However, nothing will pass traffic to it now. I can ping it without issues, but I can’t connect to any of services being ran on it. All ports seem to deny the connection.

Port 80:

(Other examples in the next few posts due to new user embed limit)

It’s showing all of the peers correctly - So not sure what’s going on now.


Unity game server:

This is all very odd. Never seen anything like this with ZT. Kinda seems like memory or disk corruption to be honest.

Also, the symbol not being found randomly like that tells me something messed up your filesystem and/or your dynamic linker is screwed. I’d run some checks on your machine.

Well, I’m not sure how it all got corrupted. But after letting it sit for a few hours it’s all working now. :face_with_hand_over_mouth:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.