Inability to connect to one machine, but others are fine (Ubuntu)

Solution: Found natterr post that suggested deleting the peers, it worked for me: Can't ping devices

I have a ZeroTier installed on Ubuntu v20 (machine A), I can ping multiple machines on a remote network via the ZeroTier Connection, but one machine (machine B) I am unable to connect to. (Destination Host Unreachable).

I can however ping that machine B and machine A from other machines on the ZeroTier network. It’s just these two that can’t see each other…

No idea what to try, any suggestions / help / ideas appreciated.

thanks for writing.
you can try downgrading the ubuntu for now. sudo apt install zerotier-one=1.4.6 Let us know if that resolves it.

Thanks zt-travis,
Deleting the peers as natterr suggested in his post seems to have resolved if for now.
But if the situation happens again I’ll try downloading and let you know.

I appear to have the same issue. Two Ubuntu laptops cannot connect to a Windows server but one Ubuntu laptop can with no issues.
Cannot see what the difference is in laptops, they are all to the same update level. Have tried downgrading the Ubuntu Zerotier version with no change in the issue.
Have tried deleting and re-adding nodes as well with no change in the issue.

When I run a packet trace on the Zerotier interface on the Ubuntu laptops, the only traffic I see is ARP requests.

Not sure what else to check.

Similar problem here: I can’t connect to/from Windows peers but Linux peers can communicate with each other just fine. Weird.

Update: tried downgrading the windows machines to 1.4.6. No dice. Looks like an issue from ZeroTier’s end.

Update 2: Android is now getting stuck at REQUESTING_CONFIGRATION.

I had so many node combination issues, that on each affected Ubuntu machine I -

  • Left the troublesome network
  • Stopped zerotier-one
  • Removed the zerotier-one package
  • Deleted the entire /var/lib/zerotier-one directory
  • Installed zerotier-one again
  • Joined network again, now with a new node address, meaning I don’t need to chase down which node can talk to which node.

After thinking more about it, simply changing your node address is probably a much quicker fix, effectively the same a deleting the node files - it’s a new node address/file.

Let us know if doing this fixes it for you -

Nope, just had the issue reappear on me. I’ve reverted back to 1.4.6 and see if the issue appears again.

I’m having the same issue between windows, ios and a router running opnsense (freebsd based firewall). The router is tethered behind NAT to a 4G phone with a public IP

Everything was working fine, shows the nodes as on-line. However since a couple of weeks ago I can’t connect between any of the nodes. No configuration changes happened apart from the opnsense router updating from 1.4.6 to 1.6.2

I reverted the router back to 1.4.6 but it didn’t help.

Frankly I’m on the verge of giving up on Zerotier. So glad I didn’t decide to roll it out to anything important

Try this, it seems to be working for me -
sudo systemctl stop zerotier-one
sudo apt remove zerotier-one
sudo rm -rf /var/lib/zerotier-one
sudo apt install zerotier-one=1.4.6
sudo apt-mark hold zerotier-one
sudo systemctl start zerotier-one

Pay attention to the bits in bold.

Just had more node issues with devices running 1.6.2.
Removing Zerotier-One from the device, deleting all config and forcing v1.4.6 seems to be working for now.

Can the devs please let us know what is happening before everyone is forced to switch to an alternative?

Bah, issues keep growing to 1.4.6 versions now.
Can’t use Zerotier at all at this rate.

Saw 1.6.3 release regarding “coma” state, any idea if these symptoms are related to the “coma” errors?

Yes, finally some traction on the issue. Have not tried the update yet, a lot of my connected nodes are quite some distance away from me, so if I lose connection, it’s not so easy to get it back.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.