Install fails on Macos Ventura 13.2

Installation fails on Ventura 13.2. Installer stops with message that I need to contact the issuer, nothing else.
Seems similar to this error report:

If I move the installer out of the Downloads directory before running the install, the installer completes without an error, but the application does not run correctly.

The other report mentions this ^.

Please post the error message you are seeing.

Tried to move the installer, but I get the same error which does not say much.

Sorry for the swedish, but it basically says that the installer failed due to an error that prevented the installation…

Thanks. We can try to reproduce it. Is it a fresh install of zerotier or an upgrade from a previous version?
Was zerotier running before the machine was upgraded to 13.2?

I have the same problem. Since version 1.10.3 it cannot be installed on mac, now I can only use 1.10.2.

Sorry for late answer - it is a fresh install which fails.

I ran into this with a new M2 MacBook Air running Ventura 13.2.1. We did a migration from an old machine that was running Mojave.

When I tried out ZeroTier on the new machine, it was working at first—- it showed up online in my ZeroTier dashboard, but with the identity of the old machine. Since we intended to keep the old machine, I wanted to create a new identity for the new machine, so I completely uninstalled ZeroTier including deleting the secrets. When I downloaded and installed, it wouldn’t work. Launching the app causes the ZeroTier icon to appear in the menu bar for a few seconds, then it disappears. No error messages that I could see. Tried redownloading and installing several times. Looked through the Privacy and Security system settings to see if there was message about a system extension being blocked from installation but nothing.

I am having the same problem. New MacBookPro M2 14". Foolishly upgraded by migrating from older MacBookPro. Running 13.3.1. Have completely cleared ZeroTier from all nooks and crannies (/Applications, /Library, ~/Library), reinstalled from scratch. Just fails to appear in menu bar and there’s no other way to interact with it.

After a bit more digging around, it looks like ZeroTier installs correctly and starts running:

  355 ??         0:00.22 zerotier-one
  691 ??         0:00.54 /Applications/

A join succeeds:

$ zerotier-cli join blahblah
200 join OK

The client shows up in ZeroTier Central, can be authorised, IP address changed, and so on.

$ zerotier-cli listnetworks
200 listnetworks <nwid> <name> <mac> <status> <type> <dev> <ZT assigned ips>
200 listnetworks blahblah DoubleBlah 22:09:56:26:91:d2 OK PRIVATE feth4026

Listing peers works. Routing table gets updates. Other hosts on 10.244/16 network reachable.

So, ZeroTier pretty much “works” under the hood. It’s just the UI that is on the fritz.

I have the same issue as well. zerotier-cli works perfectly fine, but the GUI does not start up. I’m on a Macbook Air M1 with Ventura 13.3.1 installed.

Perhaps you have too many menu bar apps running. You could try using something like Bartender to see all menu bar apps


Two other great open source alternatives are “Hidden Bar” and “Dozer” that can be installed using App Store or Homebrew.

1 Like

I feel so silly now. I never knew that it was a menu bar only application! In fact, I didn’t know that there was such a thing as a “menu bar only application” until now. Thought it was supposed to launch like any other GUI app found on the Launchpad.

Besides the GUI that you will find in the mac’s “menu bar”, you might use the “zerotier-cli” command line app with the same result.

I too am getting the generic installation failure error. I’m on Ventura 13.4, on MBP with M1.

I had a previous version 1.6.x installed and running fine… I removed that from my system, and any/all new install attempts fail. I have tried moving backwards to prior versions, and all installations fail.

Are there any solutions at this point? Anything I can try? I don’t understand the CLI references, since I can’t install ZeroTier in the first place. Thanks!

Update: I resolved my issue. I was attempting to perform the install with the PKG file in my Downloads folder. It would only work for me after I moved the PKG file to the Application folder.

This appears to be a macOS issue:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.