Port Error Windows 10

Any reason I’m getting this one windows 10.
Two devices are getting PORT_ERROR as the status.

Having the exact same issue, 2 new installs, Win10, same error. Tried this

https://zerotier.atlassian.net/wiki/spaces/SD/pages/35455014/PORT+ERROR+on+Windows

But i get “the hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tempering.”

Update: A reboot of both machines resolved this issue.

Reboot has not solved the issue

The documentation states to use the inf from “ProgramData” but that claims to be corrupt, however the one in the “Program Files” folder seems to register and solved mine

1 Like

Same problem here.

ZeroTier interfaces are missing on a fresh Windows 10 install and restarting system doesn’t help.

When I reinstall ZT I suddenly get five ZT interfaces, one of which gets IP address but no connectivity. One more reboot and it works.

Not the best update I guess.

It’s actually the first time I’m getting this error… Not sure what causes it. I’ll try an older version and see if that works.

OK so I uninstalled the latest version and reinstalled the previous version and It worked. I noticed with the new download there is no “Virtual Adapter” Present in the Adapter section of Windows. The previous one creates a Virtual adapter hence connecting.

Could this be a bug?

For me, it went well by choosing the zttap300 Driver manually for the created Zerotap Network Interface.
c:\ProgramFiles\ZeroTier\ZeroTierOneVirtualNetworkPort\zttap300
After that, the Networkconnection comes up immediately.

Fresh Win10 Pro 64bit up2date on ESXi 7.0 behind FritzBox 7590, Zerotier fresh install Zerotier 1.6.0

Bugs during installation seems to be only on Windows. On Mac and Iphone, there hadn´t been issues so far.

Br
Dominik

There seems to be a bug in Windows that is causing the driver to fail to load after a certain amount of time. We’re still digging into the cause, but rolling back to 1.4.6 we found the same issue there.

Digging into windows internals, after several network joins (loading the driver & creating a virtual adapter), Windows no longer recognizes the code signature on the driver as valid, even though it’s recognized as valid on first boot. Rolling back to 1.4.6 we discovered we could get the same behavior. None of the actual driver loading code for Windows has changed between 1.4.6 and now either, so we’re really not sure what’s causing the issue as of yet. Only workaround we have at the moment is to reboot when ZeroTier gets stuck in this state, and don’t leave/join networks repeatedly.

So i did this again on another device and it started working. It’s quite odd must say.

i have the same problem, seems like while it is trying to install again and again in device manager i force update and search automatically it installs the driver. But still a problem 20h2 windows 5 pcs install same problem and all pcs are having a memory and hdd hog. the cpu and the memory are used 100% . let me say i have been using logmein on my networks for a long time. wanted to try this. Looks like nothing is stable to be used in production environment.

Hi Boxy,
What I’ll say is it might be this version that is unstable after the update. However, the previous version was quite stable, Have implemented it in various locations without any problems. Lets give the Devs some time to find and fix bugs :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.