ZeroTier not compatible with QTS 5.0.1

I upgraded the operating system to QTS 5.0.1 and couldn’t run Zerotier (ZT) so I switched to the latest ZT version 1.8.4 but it shows the following log content:
“Failed to install ZeroTier. Downgrade QTS to 5.0.0 or an older compatible version.”

Can you please provide any advice to run any ZT version without downgradind QTS version?

Thank you in advance!

1 Like

Hi, do you find any method?

1 Like

You have to wait for someone to update the QTS package or drop zerotier into a virtual machine instead.

1 Like

hi this is simpler and better and works (only x64 cant test others)
use docker first install QVPN for the tun driver

docker run -d --name zerotier-one --device=/dev/net/tun --net=host --cap-add=NET_ADMIN --cap-add=SYS_ADMIN -v $HOME/docker/zerotier-one:/var/lib/zerotier-one --restart=always zyclonite/zerotier

docker exec zerotier-one zerotier-cli join 8056c2e21c000001

or create an empty file with the network as name
/var/lib/zerotier-one/networks.d/8056c2e21c000001.conf