Android 1.10.3 Problems continued

I was blocked from adding further comments to the original thread (max of 3 posts???) so I’ve reluctantly started a new one.

On first installing 1.10.3-3 things seemed to deteriorate further but after a few restarts and “IPv6 toggles” it’s now performing very much like 1.10.3-2. Certainly no improvement accessing Win11 box. May be a little more stable, 1.10.3-2 kept dropping out but too early to tell.

1 Like

I am also experiencing issues since the 1.10.3 update. I’m unable to connect at all from my Pixel 5a Android 13. I’m running Zerotier 1.10.3-3.

I have other machines on the network, windows, linux, raspberry pi, and all are working and fine.

I’m happy to provide more information or do some testing if it will help.

We are working on fixing the Android app and are having trouble reproducing the issues that people are seeing. For anyone who is experiencing problems, please fully describe your device, your network setup, precisely what actions you are taking, and precisely what bad behavior you are seeing.

I’m having a similar issue to @UrsaMajor Pixel 7 running Android 13. App updated to 1.10.3 and after that despite ZeroTier’s web interface saying that my phone is connected and online, I cannot access my Windows desktop through ZeroTier. My wife has a Pixel 6a and has the same issue. However, I can access ZeroTier through my home computers just fine, so this seems isolated to Android. I tried to remove my phone from my ZeroTier network, reinstall the app, and add the phone back to my network. Now when I try to connect my phone the app repeatedly crashes. I finally managed to get it stable and to say “connected” on my phone, but the phone is no longer showing up at all on the ZeroTier web interface.

Affected device: Google Pixel 5a running Android 13 Build TQ1A.230205.002

Zerotier Network contains:
3 Windows 10 computers
2 Raspberry Pis
1 Android Device (Pixel 5a above)

All devices are functioning as expected except the Pixel 5a.
Issues started with 1.10.x update
Downgrading to 1.8 6-1 fully resolves all issues.

Behavior for 1.10.3-3
Turn on toggle switch
Message at bottom of the screen eventually says ONLINE
Website shows device is online
Website shows unknown for Physical IP
Pixel 5a device cannot reach any other machine on the VPN
Key icon never shows in notification bar
Return to app and toggle button has moved to off
Toggling IPV6 checkbox doesn’t seem to make a difference (others indicated it helped)
Wifi and Cell data behave the same

Samsung S9
App version shows ZT 1.10.3-3
Web Version says 1.10.4
cellular data

After a reboot ZT is not online.
Go to app and toggle to on.
Says online but will not connect to either of my 2 other devices. I do not have the vpn “key” in the top status bar.

If I tap on the entry in the app and go to configuration and select Network DNS and then turn on the VPN it says “requesting configuration”, connects, I get the symbol at the top and connections work.

But it does not last until a reboot. No clue if the app crashes or what

We too have many users who can’t connect to our ZT net after the Android 1.10.3-3 update. Even with the slider to the right, the connection goes offline by itself.


The same thing happened to me, from the mobile phone with Android it did not connect.


It seems that when updating it does not read the configuration that it had before.

Thinking back, I think it has already happened again.

I hope it works for you.

Good day.

1 Like

Changing the DNS to Network and back to Custom worked for me.

It’s a bit annoying having two separate threads for this. Is there any chance that an admit can merge the two?

1 Like

To help with the problem-solving… I have a problem when using two Android devices - a phone and a tablet (using either wifi or GSM) to access a BlueIris server on a Windows PC. No problems accessing the server via another Windows PC. All had been working fine until recently. Details as follows:

Android Phone: Redmi Note 11 (MIUI version 13.0.3, Android version 12.SKQ1.211103.001): Zerotier:
Samsung Galaxy Tab A8 (SM-x200) Android version 13; Zerotier:

(Both devices initially go online but then drop to offline after a while)

Windows PC - Windows 10 operating system operating; BlueIris server ( Zerotier: 1.10.4


This seems to have resolved it for me.

Yesterday I removed ZT1 from both of my Android devices.
Installed ZT1 via the apk link and got v 1.8.6-1
Both devices worked.
Today they both updated to v 1.10.3-3 and both not working again.
Re-installing 1.8.6-1 via apk link and disabling auto update.
Waiting for word from ZT devs acknowledging they are working on a patch.
v 1.10.3-3 clearly does not work.

My android device is a realme 8 and my device hasn’t a node address set
what can I do?

I also can not get an Android phone to work. Was flawless for months (years?) prior to update.

Running a OnePlus 8, using Zero Tier to connect to a Blue Iris Security Server/PC (Windows 10) over Starlink. Outside of the BI server, I can remote into the system via other sources (AnyDesk) no problem (AnyDesk does not need Zero Tier).

Its basically worthless now. It disconnects by itself, and most of the time even when it says its “connected”, I can’t establish communication with the System.

Went from “It just works” to “It never works” in one update. Confidence is your execution is gone; esp considering the number of complaints and the fact you haven’t figured out at this point you probably need to roll back while you get your $hit together.

1 Like

App Version updated 4 days ago (now 13/03/23) to and like @agowans427 mentions app has become unusable overnight. Connects to a network but goes offline when I move to another app, i.e. for viewing my cameras, slider bar shows connected but says offline at the bottom of the screen. Also I do not get the status notification at the top of the screen “the Key shaped icon”, although Zerotier notifications are enabled in the phones notifications settings. Great pity because it has worked well ever since I started using it. Just installed 1.10.5 PC version and all seems fine there. Hope this gets sorted soon

1 Like

We’re looking into the additional issues. From what @brenton.bostick said in this morning’s meeting, he’s found a way to reproduce some of the issues reported, but only in difficult to debug situations. It only happens in Release builds and can take a significant amount of time to reproduce sometimes, which slows down the debug cycle further.

The previous release is still available from our download page if you wish to downgrade in the meantime. Sorry for the issues, and thank you for your help and patience in solving the issues.

1 Like

Hi, thanks for responding.
It’s either something in your latest release build, or something Google/Android did, probably the former. Can you not recover the previously known good build and release it with an up-reved ver to bypass Google’s versioning restrictions…?

1 Like

Just installed v1.10.4-2. No improvement whatsoever! Even when app says connected I cannot access my LAN devices by wifi nor 4G. Not in a position to see what shows in dashboard .
This is starting to get seriously concerning.

1 Like

Just updated one of my Android device to 1.10.4
The issue has not been fixed
Device showing online on my ZT dashboard, but the device is not connecting to the net resources.
1.10.4 IS NOT a fix.
Rolling back to the stable 1.8.6
We have the 1.8.6 apk on google drive if anyone needs the link (in case ZT changes their apk link to a failed version)

HI, same here, installed update 1.10.4, problem not fixed.

@jason.piazza yes would link the link to the 1.8.6 apk please if you could share. Thanks